Daemon Power

The NetBSD Packages Collection: www/py-yarl

Brief description of the package:
Yet another URL library

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/aio-libs/yarl.

Please note that this package has a apache-2.0 license.

The package is located in the "www/py-yarl" directory. The current source version of the package is "py38-yarl-1.6.3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/py-yarl :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py38-idna>=2.0 py38-setuptools-[0-9]* py38-expat-[0-9]* python38>=3.8 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python38>=3.8.0 python38>=3.8.7 py38-multidict>=4.0 py38-cython>=0.12.1 py38-test-runner-[0-9]* py38-setuptools_scm-[0-9]* py38-toml-[0-9]* py38-test-[0-9]* py38-attrs>=17.4.0 py38-iniconfig-[0-9]* py38-packaging-[0-9]* py38-pyparsing>=2.0.2 py38-six-[0-9]* py38-pluggy>=0.12 py38-py>=1.8.2 .

This package requires the following package(s) to run: py38-idna>=2.0 py38-setuptools-[0-9]* py38-expat-[0-9]* python38>=3.8 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python38>=3.8.0 python38>=3.8.7 py38-multidict>=4.0 py38-cython>=0.12.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:py36-yarl-1.4.2.tgz(NetBSD 9.0)
aarch64:py37-yarl-1.4.2.tgz(NetBSD 9.0)
aarch64:py38-yarl-1.4.2.tgz(NetBSD 9.0)
aarch64:py36-yarl-1.5.1.tgz(NetBSD 9.0)
aarch64:py37-yarl-1.5.1.tgz(NetBSD 9.0)
aarch64:py38-yarl-1.5.1.tgz(NetBSD 9.0)
aarch64:py36-yarl-1.6.3.tgz(NetBSD 9.0)
aarch64:py37-yarl-1.6.3.tgz(NetBSD 9.0)
aarch64:py38-yarl-1.6.3.tgz(NetBSD 9.0)
aarch64:py39-yarl-1.6.3.tgz(NetBSD 9.0)
alpha:py36-yarl-1.5.1.tgz(NetBSD 9.0)
alpha:py37-yarl-1.5.1.tgz(NetBSD 9.0)
alpha:py38-yarl-1.5.1.tgz(NetBSD 9.0)
alpha:py36-yarl-1.4.2.tgz(NetBSD 9.0)
alpha:py37-yarl-1.4.2.tgz(NetBSD 9.0)
alpha:py38-yarl-1.4.2.tgz(NetBSD 9.0)
alpha:py36-yarl-1.6.3.tgz(NetBSD 9.0)
alpha:py37-yarl-1.6.3.tgz(NetBSD 9.0)
alpha:py38-yarl-1.6.3.tgz(NetBSD 9.0)
alpha:py39-yarl-1.6.3.tgz(NetBSD 9.0)
earm:py36-yarl-1.5.1.tgz(NetBSD 9.0)
earm:py37-yarl-1.5.1.tgz(NetBSD 9.0)
earm:py38-yarl-1.5.1.tgz(NetBSD 9.0)
earm:py36-yarl-1.4.2.tgz(NetBSD 9.0)
earm:py37-yarl-1.4.2.tgz(NetBSD 9.0)
earm:py38-yarl-1.4.2.tgz(NetBSD 9.0)
earmv6hf:py36-yarl-1.5.1.tgz(NetBSD 9.0)
earmv6hf:py37-yarl-1.5.1.tgz(NetBSD 9.0)
earmv6hf:py38-yarl-1.5.1.tgz(NetBSD 9.0)
earmv6hf:py36-yarl-1.4.2.tgz(NetBSD 9.0)
earmv6hf:py37-yarl-1.4.2.tgz(NetBSD 9.0)
earmv6hf:py38-yarl-1.4.2.tgz(NetBSD 9.0)
earmv6hf:py36-yarl-1.6.3.tgz(NetBSD 9.0)
earmv6hf:py37-yarl-1.6.3.tgz(NetBSD 9.0)
earmv6hf:py38-yarl-1.6.3.tgz(NetBSD 9.0)
earmv6hf:py39-yarl-1.6.3.tgz(NetBSD 9.0)
earmv6hf:py36-yarl-1.6.3.tgz(NetBSD 9.0)
earmv6hf:py37-yarl-1.6.3.tgz(NetBSD 9.0)
earmv6hf:py38-yarl-1.6.3.tgz(NetBSD 9.0)
earmv6hf:py39-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py36-yarl-1.4.2.tgz(NetBSD 8.0)
earmv7hf:py37-yarl-1.4.2.tgz(NetBSD 8.0)
earmv7hf:py38-yarl-1.4.2.tgz(NetBSD 8.0)
earmv7hf:py36-yarl-1.4.2.tgz(NetBSD 8.0)
earmv7hf:py37-yarl-1.4.2.tgz(NetBSD 8.0)
earmv7hf:py38-yarl-1.4.2.tgz(NetBSD 8.0)
earmv7hf:py36-yarl-1.5.1.tgz(NetBSD 8.0)
earmv7hf:py37-yarl-1.5.1.tgz(NetBSD 8.0)
earmv7hf:py38-yarl-1.5.1.tgz(NetBSD 8.0)
earmv7hf:py36-yarl-1.6.3.tgz(NetBSD 8.0)
earmv7hf:py37-yarl-1.6.3.tgz(NetBSD 8.0)
earmv7hf:py38-yarl-1.6.3.tgz(NetBSD 8.0)
earmv7hf:py39-yarl-1.6.3.tgz(NetBSD 8.0)
earmv7hf:py36-yarl-1.4.2.tgz(NetBSD 9.0)
earmv7hf:py37-yarl-1.4.2.tgz(NetBSD 9.0)
earmv7hf:py38-yarl-1.4.2.tgz(NetBSD 9.0)
earmv7hf:py36-yarl-1.4.2.tgz(NetBSD 9.0)
earmv7hf:py37-yarl-1.4.2.tgz(NetBSD 9.0)
earmv7hf:py38-yarl-1.4.2.tgz(NetBSD 9.0)
earmv7hf:py36-yarl-1.5.1.tgz(NetBSD 9.0)
earmv7hf:py37-yarl-1.5.1.tgz(NetBSD 9.0)
earmv7hf:py38-yarl-1.5.1.tgz(NetBSD 9.0)
earmv7hf:py36-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py37-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py38-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py39-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py36-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py37-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py38-yarl-1.6.3.tgz(NetBSD 9.0)
earmv7hf:py39-yarl-1.6.3.tgz(NetBSD 9.0)
i386:py36-yarl-1.4.2.tgz(NetBSD 8.0)
i386:py37-yarl-1.4.2.tgz(NetBSD 8.0)
i386:py38-yarl-1.4.2.tgz(NetBSD 8.0)
i386:py36-yarl-1.5.1.tgz(NetBSD 8.0)
i386:py37-yarl-1.5.1.tgz(NetBSD 8.0)
i386:py38-yarl-1.5.1.tgz(NetBSD 8.0)
i386:py36-yarl-1.6.3.tgz(NetBSD 8.0)
i386:py37-yarl-1.6.3.tgz(NetBSD 8.0)
i386:py38-yarl-1.6.3.tgz(NetBSD 8.0)
i386:py39-yarl-1.6.3.tgz(NetBSD 8.0)
i386:py36-yarl-1.4.2.tgz(NetBSD 9.0)
i386:py37-yarl-1.4.2.tgz(NetBSD 9.0)
i386:py38-yarl-1.4.2.tgz(NetBSD 9.0)
i386:py36-yarl-1.5.1.tgz(NetBSD 9.0)
i386:py37-yarl-1.5.1.tgz(NetBSD 9.0)
i386:py38-yarl-1.5.1.tgz(NetBSD 9.0)
i386:py36-yarl-1.6.3.tgz(NetBSD 9.0)
i386:py37-yarl-1.6.3.tgz(NetBSD 9.0)
i386:py38-yarl-1.6.3.tgz(NetBSD 9.0)
i386:py39-yarl-1.6.3.tgz(NetBSD 9.0)
m68k:py36-yarl-1.5.1.tgz(NetBSD 9.0)
m68k:py37-yarl-1.5.1.tgz(NetBSD 9.0)
mips64eb:py36-yarl-1.5.1.tgz(NetBSD 9.0)
mips64eb:py37-yarl-1.5.1.tgz(NetBSD 9.0)
mips64eb:py38-yarl-1.5.1.tgz(NetBSD 9.0)
mips64eb:py36-yarl-1.6.3.tgz(NetBSD 9.0)
mips64eb:py37-yarl-1.6.3.tgz(NetBSD 9.0)
mips64eb:py38-yarl-1.6.3.tgz(NetBSD 9.0)
mips64eb:py39-yarl-1.6.3.tgz(NetBSD 9.0)
powerpc:py36-yarl-1.5.1.tgz(NetBSD 8.0)
powerpc:py37-yarl-1.5.1.tgz(NetBSD 8.0)
powerpc:py38-yarl-1.5.1.tgz(NetBSD 8.0)
powerpc:py36-yarl-1.5.1.tgz(NetBSD 9.0)
powerpc:py37-yarl-1.5.1.tgz(NetBSD 9.0)
powerpc:py38-yarl-1.5.1.tgz(NetBSD 9.0)
powerpc:py36-yarl-1.4.2.tgz(NetBSD 9.0)
powerpc:py37-yarl-1.4.2.tgz(NetBSD 9.0)
powerpc:py38-yarl-1.4.2.tgz(NetBSD 9.0)
sh3el:py37-yarl-1.5.1.tgz(NetBSD 9.0)
sparc64:py36-yarl-1.5.1.tgz(NetBSD 9.0)
sparc64:py37-yarl-1.5.1.tgz(NetBSD 9.0)
sparc64:py38-yarl-1.5.1.tgz(NetBSD 9.0)
sparc64:py36-yarl-1.4.2.tgz(NetBSD 9.0)
sparc64:py37-yarl-1.4.2.tgz(NetBSD 9.0)
sparc64:py38-yarl-1.4.2.tgz(NetBSD 9.0)
sparc64:py36-yarl-1.6.3.tgz(NetBSD 9.0)
sparc64:py37-yarl-1.6.3.tgz(NetBSD 9.0)
sparc64:py38-yarl-1.6.3.tgz(NetBSD 9.0)
sparc64:py39-yarl-1.6.3.tgz(NetBSD 9.0)
sparc:py36-yarl-1.5.1.tgz(NetBSD 9.0)
sparc:py37-yarl-1.5.1.tgz(NetBSD 9.0)
sparc:py38-yarl-1.5.1.tgz(NetBSD 9.0)
sparc:py36-yarl-1.4.2.tgz(NetBSD 9.0)
sparc:py37-yarl-1.4.2.tgz(NetBSD 9.0)
sparc:py38-yarl-1.4.2.tgz(NetBSD 9.0)
sparc:py38-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py36-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py37-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py38-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py39-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py36-yarl-1.5.1.tgz(NetBSD 9.0)
x86_64:py37-yarl-1.5.1.tgz(NetBSD 9.0)
x86_64:py38-yarl-1.5.1.tgz(NetBSD 9.0)
x86_64:py36-yarl-1.5.1.tgz(NetBSD 8.0)
x86_64:py37-yarl-1.5.1.tgz(NetBSD 8.0)
x86_64:py38-yarl-1.5.1.tgz(NetBSD 8.0)
x86_64:py36-yarl-1.4.2.tgz(NetBSD 8.0)
x86_64:py37-yarl-1.4.2.tgz(NetBSD 8.0)
x86_64:py38-yarl-1.4.2.tgz(NetBSD 8.0)
x86_64:py36-yarl-1.6.3.tgz(NetBSD 8.0)
x86_64:py37-yarl-1.6.3.tgz(NetBSD 8.0)
x86_64:py38-yarl-1.6.3.tgz(NetBSD 8.0)
x86_64:py39-yarl-1.6.3.tgz(NetBSD 8.0)
x86_64:py36-yarl-1.4.2.tgz(NetBSD 9.0)
x86_64:py37-yarl-1.4.2.tgz(NetBSD 9.0)
x86_64:py38-yarl-1.4.2.tgz(NetBSD 9.0)
x86_64:py36-yarl-1.5.1.tgz(NetBSD 9.0)
x86_64:py37-yarl-1.5.1.tgz(NetBSD 9.0)
x86_64:py38-yarl-1.5.1.tgz(NetBSD 9.0)
x86_64:py36-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py37-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py38-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py39-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py36-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py37-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py38-yarl-1.6.3.tgz(NetBSD 9.0)
x86_64:py39-yarl-1.6.3.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]