wm/bmpanel2 - The NetBSD Packages Collection

NETWM-compatible panel for X11

Nice NETWM-compatible panel for X11. Features:

* Look'n'feel customization via themes.
* A bunch of widgets: desktop switcher, taskbar, launchbar, systray,
  clock, decor, empty.
* Pseudo-transparency support.
* Written in C with speed and clarity in mind.
* Small number of dependencies, briefly: glib2, cairo, pango,
  libX11.
* Small memory footprint (about 2-4 megabytes).
* Small executable (80 kilobytes at the moment).

Build dependencies

textproc/asciidoc pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/pkgconf

Runtime dependencies

devel/glib2 devel/pango graphics/cairo lang/python27 devel/glib2 devel/pango graphics/cairo lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfbmpanel2-2.1pre1nb28.tgz
NetBSD 8.0earmv7hfbmpanel2-2.1pre1nb28.tgz
NetBSD 8.0i386bmpanel2-2.1pre1nb27.tgz
NetBSD 8.0i386bmpanel2-2.1pre1nb28.tgz
NetBSD 8.0i386bmpanel2-2.1pre1nb28.tgz
NetBSD 8.0powerpcbmpanel2-2.1pre1nb27.tgz
NetBSD 8.0powerpcbmpanel2-2.1pre1nb28.tgz
NetBSD 8.0powerpcbmpanel2-2.1pre1nb28.tgz
NetBSD 8.0x86_64bmpanel2-2.1pre1nb27.tgz
NetBSD 8.0x86_64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0aarch64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0aarch64bmpanel2-2.1pre1nb27.tgz
NetBSD 9.0aarch64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0alphabmpanel2-2.1pre1nb28.tgz
NetBSD 9.0alphabmpanel2-2.1pre1nb27.tgz
NetBSD 9.0alphabmpanel2-2.1pre1nb28.tgz
NetBSD 9.0earmv6hfbmpanel2-2.1pre1nb28.tgz
NetBSD 9.0earmv6hfbmpanel2-2.1pre1nb27.tgz
NetBSD 9.0earmv6hfbmpanel2-2.1pre1nb28.tgz
NetBSD 9.0earmv6hfbmpanel2-2.1pre1nb28.tgz
NetBSD 9.0earmv7hfbmpanel2-2.1pre1nb28.tgz
NetBSD 9.0earmv7hfbmpanel2-2.1pre1nb27.tgz
NetBSD 9.0earmv7hfbmpanel2-2.1pre1nb28.tgz
NetBSD 9.0earmv7hfbmpanel2-2.1pre1nb28.tgz
NetBSD 9.0i386bmpanel2-2.1pre1nb27.tgz
NetBSD 9.0i386bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0mips64ebbmpanel2-2.1pre1nb27.tgz
NetBSD 9.0powerpcbmpanel2-2.1pre1nb28.tgz
NetBSD 9.0powerpcbmpanel2-2.1pre1nb27.tgz
NetBSD 9.0sparc64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0sparc64bmpanel2-2.1pre1nb27.tgz
NetBSD 9.0sparc64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0sparcbmpanel2-2.1pre1nb27.tgz
NetBSD 9.0x86_64bmpanel2-2.1pre1nb27.tgz
NetBSD 9.0x86_64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0x86_64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0x86_64bmpanel2-2.1pre1nb27.tgz
NetBSD 9.0x86_64bmpanel2-2.1pre1nb28.tgz
NetBSD 9.0x86_64bmpanel2-2.1pre1nb28.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.