wm/blackbox - The NetBSD Packages Collection

Small and fast X11 window manager

Blackbox is yet another addition to the list of window managers for X11.
Blackbox is built with C++, sharing no common code with any other window
manager.  It is designed to be small and fast, with a built in graphics class,
near complete ICCCM compliance, and support for multple desktop environments.

Build dependencies

pkgtools/x11-links x11/xorgproto pkgtools/cwrappers devel/libtool-base archivers/lzip devel/pkgconf

Runtime dependencies

fonts/Xft2 fonts/Xft2 fonts/Xft2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfblackbox-0.65.0nb7.tgz
NetBSD 8.0earmv7hfblackbox-0.65.0nb7.tgz
NetBSD 8.0i386blackbox-0.65.0nb7.tgz
NetBSD 8.0i386blackbox-0.65.0nb7.tgz
NetBSD 8.0i386blackbox-0.65.0nb7.tgz
NetBSD 8.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 8.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 8.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 8.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 8.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 8.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 8.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 9.0aarch64blackbox-0.65.0nb7.tgz
NetBSD 9.0aarch64blackbox-0.65.0nb7.tgz
NetBSD 9.0alphablackbox-0.65.0nb7.tgz
NetBSD 9.0alphablackbox-0.65.0nb7.tgz
NetBSD 9.0alphablackbox-0.65.0nb7.tgz
NetBSD 9.0earmv6hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv6hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv6hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv6hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv7hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv7hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv7hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv7hfblackbox-0.65.0nb7.tgz
NetBSD 9.0earmv7hfblackbox-0.65.0nb7.tgz
NetBSD 9.0i386blackbox-0.65.0nb7.tgz
NetBSD 9.0i386blackbox-0.65.0nb7.tgz
NetBSD 9.0i386blackbox-0.65.0nb7.tgz
NetBSD 9.0m68kblackbox-0.65.0nb7.tgz
NetBSD 9.0m68kblackbox-0.65.0nb7.tgz
NetBSD 9.0mips64ebblackbox-0.65.0nb7.tgz
NetBSD 9.0mips64ebblackbox-0.65.0nb7.tgz
NetBSD 9.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 9.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 9.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 9.0powerpcblackbox-0.65.0nb7.tgz
NetBSD 9.0sparc64blackbox-0.65.0nb7.tgz
NetBSD 9.0sparc64blackbox-0.65.0nb7.tgz
NetBSD 9.0sparc64blackbox-0.65.0nb7.tgz
NetBSD 9.0sparcblackbox-0.65.0nb7.tgz
NetBSD 9.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 9.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 9.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 9.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 9.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 9.0x86_64blackbox-0.65.0nb7.tgz
NetBSD 9.0x86_64blackbox-0.65.0nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

nls
Use native language support.
xft2
Enable Xft support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.