time/p5-DateTime-Format-Pg - The NetBSD Packages Collection

Parse and format PostgreSQL dates and times

This module understands the formats used by PostgreSQL for its
DATE, TIME, TIMESTAMP, and INTERVAL data types. It can be used to
parse these formats in order to create DateTime or DateTime::Duration
objects, and it can take a DateTime or DateTime::Duration object
and produce a string representing it in a format accepted by
PostgreSQL.

Build dependencies

devel/p5-Sub-Name devel/p5-Module-Build-Tiny pkgtools/cwrappers

Runtime dependencies

time/p5-DateTime time/p5-DateTime-Format-Builder time/p5-DateTime-TimeZone lang/perl5 lang/perl5

Available binary packages

aarch64:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
aarch64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
aarch64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
alpha:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
alpha:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
alpha:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earm:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earm:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
earm:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earmv6hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earmv6hf:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
earmv6hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earmv6hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 8.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 8.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
earmv7hf:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
i386:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 8.0)
i386:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
i386:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
i386:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
i386:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
i386:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
m68k:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
mips64eb:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
mips64eb:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
mipsel:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
powerpc:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
powerpc:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
powerpc:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
powerpc:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
sh3el:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
sh3el:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
sparc64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
sparc64:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
sparc64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
sparc:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
sparc:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
sparc:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 8.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 8.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb2.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)
x86_64:p5-DateTime-Format-Pg-0.16013nb3.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]