textproc/ruby-haml - The NetBSD Packages Collection

XHTML & CSS markup language & template engine

Haml (HTML Abstraction Markup Language) is a layer on top of XHTML or
XML that's designed to express the structure of XHTML or XML documents
in a non-repetitive, elegant, easy way, using indentation rather than
closing tags and allowing Ruby to be embedded with ease.  It was
originally envisioned as a plugin for Ruby on Rails, but it can
function as a stand-alone templating engine.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/ruby-temple textproc/ruby-tilt lang/ruby27-base

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfruby26-haml-5.2.2.tgz
NetBSD 8.0earmv7hfruby27-haml-5.2.2.tgz
NetBSD 8.0earmv7hfruby25-haml-5.2.1.tgz
NetBSD 8.0earmv7hfruby26-haml-5.2.1.tgz
NetBSD 8.0earmv7hfruby27-haml-5.2.1.tgz
NetBSD 8.0earmv7hfruby26-haml-5.2.1.tgz
NetBSD 8.0earmv7hfruby27-haml-5.2.1.tgz
NetBSD 8.0i386ruby25-haml-5.2.1.tgz
NetBSD 8.0i386ruby26-haml-5.2.1.tgz
NetBSD 8.0i386ruby27-haml-5.2.1.tgz
NetBSD 8.0i386ruby26-haml-5.2.1.tgz
NetBSD 8.0i386ruby27-haml-5.2.1.tgz
NetBSD 8.0powerpcruby25-haml-5.2.1.tgz
NetBSD 8.0powerpcruby26-haml-5.2.1.tgz
NetBSD 8.0powerpcruby27-haml-5.2.1.tgz
NetBSD 8.0powerpcruby25-haml-5.2.1.tgz
NetBSD 8.0powerpcruby26-haml-5.2.1.tgz
NetBSD 8.0powerpcruby27-haml-5.2.1.tgz
NetBSD 8.0powerpcruby25-haml-5.2.1.tgz
NetBSD 8.0powerpcruby26-haml-5.2.1.tgz
NetBSD 8.0powerpcruby27-haml-5.2.1.tgz
NetBSD 8.0powerpcruby26-haml-5.2.2.tgz
NetBSD 8.0powerpcruby27-haml-5.2.2.tgz
NetBSD 8.0x86_64ruby25-haml-5.2.1.tgz
NetBSD 8.0x86_64ruby26-haml-5.2.1.tgz
NetBSD 8.0x86_64ruby27-haml-5.2.1.tgz
NetBSD 8.0x86_64ruby26-haml-5.2.1.tgz
NetBSD 8.0x86_64ruby27-haml-5.2.1.tgz
NetBSD 9.0aarch64ruby26-haml-5.2.2.tgz
NetBSD 9.0aarch64ruby27-haml-5.2.2.tgz
NetBSD 9.0aarch64ruby30-haml-5.2.2.tgz
NetBSD 9.0aarch64ruby25-haml-5.2.1.tgz
NetBSD 9.0aarch64ruby26-haml-5.2.1.tgz
NetBSD 9.0aarch64ruby27-haml-5.2.1.tgz
NetBSD 9.0aarch64ruby30-haml-5.2.1.tgz
NetBSD 9.0aarch64ruby26-haml-5.2.1.tgz
NetBSD 9.0aarch64ruby27-haml-5.2.1.tgz
NetBSD 9.0aarch64ruby30-haml-5.2.1.tgz
NetBSD 9.0alpharuby26-haml-5.2.2.tgz
NetBSD 9.0alpharuby27-haml-5.2.2.tgz
NetBSD 9.0alpharuby25-haml-5.2.1.tgz
NetBSD 9.0alpharuby26-haml-5.2.1.tgz
NetBSD 9.0alpharuby27-haml-5.2.1.tgz
NetBSD 9.0alpharuby25-haml-5.2.1.tgz
NetBSD 9.0alpharuby26-haml-5.2.1.tgz
NetBSD 9.0alpharuby27-haml-5.2.1.tgz
NetBSD 9.0earmv6hfruby26-haml-5.2.2.tgz
NetBSD 9.0earmv6hfruby27-haml-5.2.2.tgz
NetBSD 9.0earmv6hfruby30-haml-5.2.2.tgz
NetBSD 9.0earmv6hfruby25-haml-5.2.1.tgz
NetBSD 9.0earmv6hfruby26-haml-5.2.1.tgz
NetBSD 9.0earmv6hfruby27-haml-5.2.1.tgz
NetBSD 9.0earmv6hfruby30-haml-5.2.1.tgz
NetBSD 9.0earmv6hfruby26-haml-5.2.1.tgz
NetBSD 9.0earmv6hfruby27-haml-5.2.1.tgz
NetBSD 9.0earmv6hfruby30-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby26-haml-5.2.2.tgz
NetBSD 9.0earmv7hfruby27-haml-5.2.2.tgz
NetBSD 9.0earmv7hfruby30-haml-5.2.2.tgz
NetBSD 9.0earmv7hfruby25-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby26-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby27-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby30-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby26-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby27-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby30-haml-5.2.1.tgz
NetBSD 9.0earmv7hfruby26-haml-5.2.2.tgz
NetBSD 9.0earmv7hfruby27-haml-5.2.2.tgz
NetBSD 9.0earmv7hfruby30-haml-5.2.2.tgz
NetBSD 9.0i386ruby25-haml-5.2.1.tgz
NetBSD 9.0i386ruby26-haml-5.2.1.tgz
NetBSD 9.0i386ruby27-haml-5.2.1.tgz
NetBSD 9.0i386ruby30-haml-5.2.1.tgz
NetBSD 9.0i386ruby26-haml-5.2.1.tgz
NetBSD 9.0i386ruby27-haml-5.2.1.tgz
NetBSD 9.0i386ruby30-haml-5.2.1.tgz
NetBSD 9.0mips64ebruby26-haml-5.2.1.tgz
NetBSD 9.0mips64ebruby27-haml-5.2.1.tgz
NetBSD 9.0mips64ebruby30-haml-5.2.1.tgz
NetBSD 9.0mips64ebruby25-haml-5.1.2.tgz
NetBSD 9.0mips64ebruby26-haml-5.1.2.tgz
NetBSD 9.0mips64ebruby27-haml-5.1.2.tgz
NetBSD 9.0mips64ebruby25-haml-5.1.2.tgz
NetBSD 9.0mips64ebruby26-haml-5.1.2.tgz
NetBSD 9.0mips64ebruby27-haml-5.1.2.tgz
NetBSD 9.0powerpcruby25-haml-5.2.1.tgz
NetBSD 9.0powerpcruby26-haml-5.2.1.tgz
NetBSD 9.0powerpcruby27-haml-5.2.1.tgz
NetBSD 9.0powerpcruby30-haml-5.2.1.tgz
NetBSD 9.0powerpcruby25-haml-5.2.1.tgz
NetBSD 9.0powerpcruby26-haml-5.2.1.tgz
NetBSD 9.0powerpcruby27-haml-5.2.1.tgz
NetBSD 9.0powerpcruby30-haml-5.2.1.tgz
NetBSD 9.0powerpcruby25-haml-5.2.1.tgz
NetBSD 9.0powerpcruby26-haml-5.2.1.tgz
NetBSD 9.0powerpcruby27-haml-5.2.1.tgz
NetBSD 9.0powerpcruby30-haml-5.2.1.tgz
NetBSD 9.0powerpcruby26-haml-5.2.2.tgz
NetBSD 9.0powerpcruby27-haml-5.2.2.tgz
NetBSD 9.0powerpcruby30-haml-5.2.2.tgz
NetBSD 9.0sparc64ruby25-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby26-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby27-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby30-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby25-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby26-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby27-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby30-haml-5.2.1.tgz
NetBSD 9.0sparc64ruby26-haml-5.2.2.tgz
NetBSD 9.0sparc64ruby27-haml-5.2.2.tgz
NetBSD 9.0sparc64ruby30-haml-5.2.2.tgz
NetBSD 9.0sparcruby25-haml-5.1.2.tgz
NetBSD 9.0sparcruby27-haml-5.1.2.tgz
NetBSD 9.0sparcruby25-haml-5.1.2.tgz
NetBSD 9.0sparcruby27-haml-5.1.2.tgz
NetBSD 9.0x86_64ruby26-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby27-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby30-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby26-haml-5.2.2.tgz
NetBSD 9.0x86_64ruby27-haml-5.2.2.tgz
NetBSD 9.0x86_64ruby30-haml-5.2.2.tgz
NetBSD 9.0x86_64ruby25-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby26-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby27-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby30-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby26-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby27-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby30-haml-5.2.1.tgz
NetBSD 9.0x86_64ruby26-haml-5.2.2.tgz
NetBSD 9.0x86_64ruby27-haml-5.2.2.tgz
NetBSD 9.0x86_64ruby30-haml-5.2.2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.