textproc/p5-XML-Rabbit - The NetBSD Packages Collection

Perl 5 module to consume XML with Moose and xpath queries

The Perl 5 module XML::Rabbit is a simple Moose-based base class
you can use to make simple XPath-based XML extractors. Each attribute
in your class is linked to an XPath query that is executed on your
XML document when you request the value.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Data-Visitor devel/p5-Moose devel/p5-MooseX-Role-Parameterized devel/p5-Perl6-Junction textproc/p5-XML-LibXML devel/p5-namespace-autoclean lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 8.0earmv7hfp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 8.0earmv7hfp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 8.0i386p5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 8.0i386p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 8.0powerpcp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 8.0powerpcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 8.0powerpcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 8.0powerpcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 8.0x86_64p5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 8.0x86_64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0aarch64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0aarch64p5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0aarch64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0alphap5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0alphap5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0alphap5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0earmv6hfp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0earmv6hfp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0earmv6hfp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0earmv7hfp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0earmv7hfp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0earmv7hfp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0earmv7hfp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0i386p5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0i386p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0i386p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0mips64ebp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0mips64ebp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0mips64ebp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0mips64ebp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0mips64ebp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0powerpcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0powerpcp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0powerpcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0powerpcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0sparc64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0sparc64p5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0sparc64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0sparcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0sparcp5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0sparcp5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0x86_64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0x86_64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0x86_64p5-XML-Rabbit-0.4.1nb5.tgz
NetBSD 9.0x86_64p5-XML-Rabbit-0.4.1nb6.tgz
NetBSD 9.0x86_64p5-XML-Rabbit-0.4.1nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.