textproc/p5-XML-Descent - The NetBSD Packages Collection

Recursive descent XML parsing

The conventional models for parsing XML are either DOM (a data structure
representing the entire document tree is created) or SAX (callbacks are
issued for each element in the XML).

XML grammar is recursive - so it's nice to be able to write recursive
parsers for it. XML::Descent allows such parsers to be created.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/p5-XML-TokeParser lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-XML-Descent-1.04nb6.tgz
NetBSD 8.0earmv7hfp5-XML-Descent-1.04nb5.tgz
NetBSD 8.0earmv7hfp5-XML-Descent-1.04nb6.tgz
NetBSD 8.0i386p5-XML-Descent-1.04nb5.tgz
NetBSD 8.0i386p5-XML-Descent-1.04nb6.tgz
NetBSD 8.0powerpcp5-XML-Descent-1.04nb5.tgz
NetBSD 8.0powerpcp5-XML-Descent-1.04nb6.tgz
NetBSD 8.0powerpcp5-XML-Descent-1.04nb6.tgz
NetBSD 8.0powerpcp5-XML-Descent-1.04nb6.tgz
NetBSD 8.0x86_64p5-XML-Descent-1.04nb5.tgz
NetBSD 8.0x86_64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0aarch64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0aarch64p5-XML-Descent-1.04nb5.tgz
NetBSD 9.0aarch64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0alphap5-XML-Descent-1.04nb6.tgz
NetBSD 9.0alphap5-XML-Descent-1.04nb5.tgz
NetBSD 9.0alphap5-XML-Descent-1.04nb6.tgz
NetBSD 9.0earmp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0earmp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0earmp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0earmv6hfp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0earmv6hfp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0earmv6hfp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0earmv7hfp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0earmv7hfp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0earmv7hfp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0earmv7hfp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0i386p5-XML-Descent-1.04nb5.tgz
NetBSD 9.0i386p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0i386p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0mips64ebp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0mips64ebp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0mips64ebp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0mips64ebp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0mips64ebp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0powerpcp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0powerpcp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0powerpcp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0powerpcp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0sparc64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0sparc64p5-XML-Descent-1.04nb5.tgz
NetBSD 9.0sparc64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0sparcp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0sparcp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0sparcp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0sparcp5-XML-Descent-1.04nb5.tgz
NetBSD 9.0sparcp5-XML-Descent-1.04nb6.tgz
NetBSD 9.0x86_64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0x86_64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0x86_64p5-XML-Descent-1.04nb5.tgz
NetBSD 9.0x86_64p5-XML-Descent-1.04nb6.tgz
NetBSD 9.0x86_64p5-XML-Descent-1.04nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.