textproc/p5-Text-WrapI18N - The NetBSD Packages Collection

Perl5 module to wrap internationalized text

This is a module which intends to substitute Text::Wrap,
which supports internationalized texts including:
 - multibyte encodings such as UTF-8, EUC-JP, EUC-KR, GB2312, and Big5,
 - fullwidth characters like east Asian characters which appear in
   UTF-8, EUC-JP, EUC-KR, GB2312, Big5, and so on,
 - combining characters like diacritical marks which appear in UTF-8,
   ISO-8859-11 (aka TIS-620), and so on, and
 - languages which don't use whitespaces between words, like Chinese
   and Japanese.

The text is to be given in locale encoding, not always in UTF-8.
(Of course locale encoding is UTF-8 in UTF-8 locales.)

Build dependencies

pkgtools/cwrappers

Runtime dependencies

textproc/p5-Text-CharWidth lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 8.0earmv7hfp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 8.0earmv7hfp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 8.0i386p5-Text-WrapI18N-0.06nb14.tgz
NetBSD 8.0i386p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 8.0powerpcp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 8.0powerpcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 8.0powerpcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 8.0powerpcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 8.0x86_64p5-Text-WrapI18N-0.06nb14.tgz
NetBSD 8.0x86_64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0aarch64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0aarch64p5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0aarch64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0alphap5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0alphap5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0alphap5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0earmp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0earmp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0earmp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0earmv6hfp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0earmv6hfp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0earmv6hfp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0earmv7hfp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0earmv7hfp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0earmv7hfp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0earmv7hfp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0i386p5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0i386p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0i386p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0m68kp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0m68kp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0mips64ebp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0mips64ebp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0mips64ebp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0mips64ebp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0mips64ebp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0mipselp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0mipselp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0mipselp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0mipselp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0powerpcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0powerpcp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0powerpcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0powerpcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0sh3elp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0sh3elp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0sh3elp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0sh3elp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0sparc64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0sparc64p5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0sparc64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0sparcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0sparcp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0sparcp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0sparcp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0sparcp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0vaxp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0vaxp5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0vaxp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0vaxp5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0x86_64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0x86_64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0x86_64p5-Text-WrapI18N-0.06nb14.tgz
NetBSD 9.0x86_64p5-Text-WrapI18N-0.06nb15.tgz
NetBSD 9.0x86_64p5-Text-WrapI18N-0.06nb15.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.