textproc/p5-FormValidator-Simple - The NetBSD Packages Collection

Validation with simple chains of constraints

This module provides you a sweet way of form data validation with
simple constraints chains. You can write constraints on single line
for each input data.

This idea is based on Sledge::Plugin::Validator, and most of
validation code is borrowed from this plugin.

(Sledge is a MVC web application framework: http://sl.edge.jp
[Japanese] )

The result object this module returns behaves like
Data::FormValidator::Results.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/p5-Class-Accessor devel/p5-Class-Data-Accessor devel/p5-Class-Data-Inheritable devel/p5-Class-Inspector devel/p5-Date-Calc time/p5-DateTime-Format-Strptime mail/p5-MailTools mail/p5-Email-Valid mail/p5-Email-Valid-Loose devel/p5-Tie-IxHash devel/p5-List-MoreUtils devel/p5-UNIVERSAL-require textproc/p5-YAML lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 8.0earmv7hfp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 8.0earmv7hfp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 8.0i386p5-FormValidator-Simple-0.29nb6.tgz
NetBSD 8.0i386p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 8.0powerpcp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 8.0powerpcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 8.0powerpcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 8.0powerpcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 8.0x86_64p5-FormValidator-Simple-0.29nb6.tgz
NetBSD 8.0x86_64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0aarch64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0aarch64p5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0aarch64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0alphap5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0alphap5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0alphap5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0earmp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0earmp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0earmp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0earmv6hfp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0earmv6hfp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0earmv6hfp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0earmv7hfp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0earmv7hfp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0earmv7hfp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0earmv7hfp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0i386p5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0i386p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0mips64ebp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0mips64ebp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0mips64ebp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0mips64ebp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0mips64ebp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0powerpcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0powerpcp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0powerpcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0powerpcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0sh3elp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0sh3elp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0sh3elp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0sh3elp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0sparc64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0sparc64p5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0sparc64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0sparcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0sparcp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0sparcp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0sparcp5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0sparcp5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0x86_64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0x86_64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0x86_64p5-FormValidator-Simple-0.29nb6.tgz
NetBSD 9.0x86_64p5-FormValidator-Simple-0.29nb7.tgz
NetBSD 9.0x86_64p5-FormValidator-Simple-0.29nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.