textproc/p5-Encode-Detect - The NetBSD Packages Collection

Perl module that detects the encoding of data

This Perl module is an Encode::Encoding subclass that uses
Encode::Detect::Detector to determine the charset of the input data and
then decodes it using the encoder of the detected charset.

It is similar to Encode::Guess, but does not require the configuration
of a set of expected encodings. Like Encode::Guess, it only supports
decoding--it cannot encode.

Build dependencies

devel/p5-Module-Build pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0earmv7hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0earmv7hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0i386p5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0i386p5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0i386p5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0powerpcp5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0powerpcp5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0powerpcp5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0x86_64p5-Encode-Detect-1.01nb12.tgz
NetBSD 8.0x86_64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0aarch64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0aarch64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0aarch64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0alphap5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0alphap5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0alphap5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv6hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv6hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv6hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv6hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv7hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv7hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv7hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0earmv7hfp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0i386p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0i386p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0mips64ebp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0mips64ebp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0mips64ebp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0powerpcp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0powerpcp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0sparc64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0sparc64p5-Encode-Detect-1.01nb11.tgz
NetBSD 9.0sparc64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0sparc64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0sparcp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0sparcp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0sparcp5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0x86_64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0x86_64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0x86_64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0x86_64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0x86_64p5-Encode-Detect-1.01nb12.tgz
NetBSD 9.0x86_64p5-Encode-Detect-1.01nb12.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.