textproc/libxml - The NetBSD Packages Collection

XML parser (version 1), mainly used by the GNOME project

This is the old XML parsing library provided in the GNOME framework.
XML is a standard to build tag based structured documents.  The
internal document representation is as close as possible to the
DOM interfaces.  The interfaces of the XML library are by principle
low level, there is nearly zero abstraction.

Some features are:

	- C++ support
	- Updated code to follow more recent specs, added
	  compatibility flag
	- Error handling, use a dedicated, overridable error
	  handling function.
	- Support for CDATA.
	- Keep track of line numbers for better error reporting.
	- Support for PI (SAX one).

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibxml-1.8.17nb4.tgz
NetBSD 8.0earmv7hflibxml-1.8.17nb4.tgz
NetBSD 8.0earmv7hflibxml-1.8.17nb4.tgz
NetBSD 8.0i386libxml-1.8.17nb4.tgz
NetBSD 8.0i386libxml-1.8.17nb4.tgz
NetBSD 8.0powerpclibxml-1.8.17nb4.tgz
NetBSD 8.0powerpclibxml-1.8.17nb4.tgz
NetBSD 8.0powerpclibxml-1.8.17nb4.tgz
NetBSD 8.0powerpclibxml-1.8.17nb4.tgz
NetBSD 8.0x86_64libxml-1.8.17nb4.tgz
NetBSD 8.0x86_64libxml-1.8.17nb4.tgz
NetBSD 9.0aarch64libxml-1.8.17nb4.tgz
NetBSD 9.0aarch64libxml-1.8.17nb4.tgz
NetBSD 9.0aarch64libxml-1.8.17nb4.tgz
NetBSD 9.0alphalibxml-1.8.17nb4.tgz
NetBSD 9.0alphalibxml-1.8.17nb4.tgz
NetBSD 9.0alphalibxml-1.8.17nb4.tgz
NetBSD 9.0earmlibxml-1.8.17nb4.tgz
NetBSD 9.0earmlibxml-1.8.17nb4.tgz
NetBSD 9.0earmlibxml-1.8.17nb4.tgz
NetBSD 9.0earmv6hflibxml-1.8.17nb4.tgz
NetBSD 9.0earmv6hflibxml-1.8.17nb4.tgz
NetBSD 9.0earmv6hflibxml-1.8.17nb4.tgz
NetBSD 9.0earmv7hflibxml-1.8.17nb4.tgz
NetBSD 9.0earmv7hflibxml-1.8.17nb4.tgz
NetBSD 9.0earmv7hflibxml-1.8.17nb4.tgz
NetBSD 9.0earmv7hflibxml-1.8.17nb4.tgz
NetBSD 9.0i386libxml-1.8.17nb4.tgz
NetBSD 9.0i386libxml-1.8.17nb4.tgz
NetBSD 9.0mips64eblibxml-1.8.17nb4.tgz
NetBSD 9.0mips64eblibxml-1.8.17nb4.tgz
NetBSD 9.0mips64eblibxml-1.8.17nb4.tgz
NetBSD 9.0mips64eblibxml-1.8.17nb4.tgz
NetBSD 9.0mips64eblibxml-1.8.17nb4.tgz
NetBSD 9.0powerpclibxml-1.8.17nb4.tgz
NetBSD 9.0powerpclibxml-1.8.17nb4.tgz
NetBSD 9.0powerpclibxml-1.8.17nb4.tgz
NetBSD 9.0powerpclibxml-1.8.17nb4.tgz
NetBSD 9.0sh3ellibxml-1.8.17nb4.tgz
NetBSD 9.0sh3ellibxml-1.8.17nb4.tgz
NetBSD 9.0sh3ellibxml-1.8.17nb4.tgz
NetBSD 9.0sh3ellibxml-1.8.17nb4.tgz
NetBSD 9.0sparc64libxml-1.8.17nb4.tgz
NetBSD 9.0sparc64libxml-1.8.17nb4.tgz
NetBSD 9.0sparc64libxml-1.8.17nb4.tgz
NetBSD 9.0sparclibxml-1.8.17nb4.tgz
NetBSD 9.0sparclibxml-1.8.17nb4.tgz
NetBSD 9.0sparclibxml-1.8.17nb4.tgz
NetBSD 9.0sparclibxml-1.8.17nb4.tgz
NetBSD 9.0sparclibxml-1.8.17nb4.tgz
NetBSD 9.0vaxlibxml-1.8.17nb4.tgz
NetBSD 9.0vaxlibxml-1.8.17nb4.tgz
NetBSD 9.0vaxlibxml-1.8.17nb4.tgz
NetBSD 9.0x86_64libxml-1.8.17nb4.tgz
NetBSD 9.0x86_64libxml-1.8.17nb4.tgz
NetBSD 9.0x86_64libxml-1.8.17nb4.tgz
NetBSD 9.0x86_64libxml-1.8.17nb4.tgz
NetBSD 9.0x86_64libxml-1.8.17nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.