Daemon Power

The NetBSD Packages Collection: textproc/libodfgen

Brief description of the package:
Library to generate ODF documents through libwpd and libwps

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://libwpd.sourceforge.net/.

Please note that this package has a mpl-2.0 license.

The package is located in the "textproc/libodfgen" directory. The current source version of the package is "libodfgen-0.1.6nb11". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for textproc/libodfgen :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: libetonyek>=0.0.3 liblangtag>=0.4.0 glib2>=2.4.0 pcre>=3.4nb1 cwrappers>=20150314 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 meson-[0-9]* ninja-build-[0-9]* python37>=3.7 libuuid>=2.18 openssl>=1.1.1 openssl>=1.1.1dnb2 readline>=2.2 readline>=6.0 python37>=3.7.0 re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.6 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 glib2>=2.34.0 libxml2>=2.8.0nb2 libwpd>=0.9.5 librevenge>=0.0.1 boost-libs-1.72.* icu>=3.4 icu>=64.1 boost-jam-1.72.* cppunit>=1.10.2 boost-libs>=1.72.0 cppunit>=1.10.2nb5 boost-headers-1.72.* librevenge>=0.0.4nb11 libwpd>=0.10.1nb11 mdds1.2>=1.2.0 glm>=0.9.7 libwpg>=0.1.3 libetonyek>=0.1.9nb3 libwpg>=0.3.1nb14 .

This package requires the following package(s) to run: libetonyek>=0.0.3 liblangtag>=0.4.0 glib2>=2.4.0 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 glib2>=2.34.0 libxml2>=2.8.0nb2 libwpd>=0.9.5 librevenge>=0.0.1 boost-libs-1.72.* icu>=3.4 icu>=64.1 cppunit>=1.10.2 boost-libs>=1.72.0 cppunit>=1.10.2nb5 librevenge>=0.0.4nb11 libwpd>=0.10.1nb11 libwpg>=0.1.3 libetonyek>=0.1.9nb3 libwpg>=0.3.1nb14 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:libodfgen-0.1.6nb10.tgz(NetBSD 9.0)
alpha:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
earm:libodfgen-0.1.4nb1.tgz(NetBSD 7.0)
earmv6hf:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
earmv6hf:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
earmv7hf:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
earmv7hf:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
earmv7hf:libodfgen-0.1.6nb10.tgz(NetBSD 9.0)
i386:libodfgen-0.1.6nb8.tgz(NetBSD 7.0)
i386:libodfgen-0.1.6nb8.tgz(NetBSD 7.0)
i386:libodfgen-0.1.6nb10.tgz(NetBSD 7.0)
i386:libodfgen-0.1.6nb8.tgz(NetBSD 7.1)
i386:libodfgen-0.1.6nb8.tgz(NetBSD 7.1)
i386:libodfgen-0.1.6nb10.tgz(NetBSD 7.1)
i386:libodfgen-0.1.6nb8.tgz(NetBSD 8.0)
i386:libodfgen-0.1.6nb8.tgz(NetBSD 8.0)
i386:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
i386:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
mips64eb:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
powerpc:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
powerpc:libodfgen-0.1.6nb8.tgz(NetBSD 9.0)
powerpc:libodfgen-0.1.6nb10.tgz(NetBSD 9.0)
sparc64:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
x86_64:libodfgen-0.1.6nb11.tgz(NetBSD 9.0)
x86_64:libodfgen-0.1.6nb8.tgz(NetBSD 7.0)
x86_64:libodfgen-0.1.6nb8.tgz(NetBSD 7.0)
x86_64:libodfgen-0.1.6nb10.tgz(NetBSD 7.0)
x86_64:libodfgen-0.1.6nb8.tgz(NetBSD 7.1)
x86_64:libodfgen-0.1.6nb8.tgz(NetBSD 7.1)
x86_64:libodfgen-0.1.6nb10.tgz(NetBSD 7.1)
x86_64:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
x86_64:libodfgen-0.1.6nb8.tgz(NetBSD 8.0)
x86_64:libodfgen-0.1.6nb8.tgz(NetBSD 8.0)
x86_64:libodfgen-0.1.6nb10.tgz(NetBSD 8.0)
x86_64:libodfgen-0.1.6nb10.tgz(NetBSD 9.0)
x86_64:libodfgen-0.1.6nb11.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]