textproc/hs-hxt - The NetBSD Packages Collection

Collection of tools for processing XML with Haskell

The Haskell XML Toolbox bases on the ideas of HaXml and HXML, but
introduces a more general approach for processing XML with
Haskell. The Haskell XML Toolbox uses a generic data model for
representing XML documents, including the DTD subset and the document
subset, in Haskell. It contains a validating XML parser, a HTML
parser, namespace support, an XPath expression evaluator, an XSLT
library, a RelaxNG schema validator and funtions for serialization and
deserialization of user defined data. The library makes extensive use
of the arrow approach for processing XML.

Since version 9 the toolbox is partitioned into various
(sub-)packages. This package contains the core functionality,
hxt-curl, hxt-tagsoup, hxt-relaxng, hxt-xpath, hxt-xslt,
hxt-regex-xmlschema contain the extensions. hxt-unicode contains
encoding and decoding functions, hxt-charproperties char properties
for unicode and XML.

Build dependencies

pkgtools/cwrappers devel/pkgconf

Runtime dependencies

textproc/hs-hxt-charproperties textproc/hs-hxt-regex-xmlschema textproc/hs-hxt-unicode net/hs-network net/hs-network-uri lang/ghc88 textproc/hs-hxt-charproperties textproc/hs-hxt-regex-xmlschema textproc/hs-hxt-unicode net/hs-network net/hs-network-uri lang/ghc88

Available binary packages

x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 8.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 8.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 8.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)
x86_64:hs-hxt-9.3.1.18.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]