textproc/glimpse - The NetBSD Packages Collection

Text search engine

Glimpse (which stands for GLobal IMPlicit SEarch) is an indexing and
query system that allows you to search through all your files very
quickly. For example, finding 296 lines containing 'whitehouse' in 8750
files occupying 104MB took 6 seconds on a SUN Sparc 5.

Glimpse supports most of agrep's options (agrep is our powerful version
of grep) including approximate matching (e.g., finding mis- spelled
words), Boolean queries, and even some limited forms of regular
expressions. It is used in the same way, except that you don't have to
specify file names. So, if you are looking for a needle anywhere in your
file system, all you have to do is say glimpse needle and all lines
containing needle will appear preceded by the file name.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfglimpse-4.18.6.tgz
NetBSD 8.0earmv7hfglimpse-4.18.6.tgz
NetBSD 8.0earmv7hfglimpse-4.18.6.tgz
NetBSD 8.0i386glimpse-4.18.6.tgz
NetBSD 8.0i386glimpse-4.18.6.tgz
NetBSD 8.0powerpcglimpse-4.18.6.tgz
NetBSD 8.0powerpcglimpse-4.18.6.tgz
NetBSD 8.0powerpcglimpse-4.18.6.tgz
NetBSD 8.0powerpcglimpse-4.18.6.tgz
NetBSD 8.0x86_64glimpse-4.18.6.tgz
NetBSD 8.0x86_64glimpse-4.18.6.tgz
NetBSD 9.0aarch64glimpse-4.18.6.tgz
NetBSD 9.0aarch64glimpse-4.18.6.tgz
NetBSD 9.0aarch64glimpse-4.18.6.tgz
NetBSD 9.0alphaglimpse-4.18.6.tgz
NetBSD 9.0alphaglimpse-4.18.6.tgz
NetBSD 9.0alphaglimpse-4.18.6.tgz
NetBSD 9.0earmglimpse-4.18.6.tgz
NetBSD 9.0earmv6hfglimpse-4.18.6.tgz
NetBSD 9.0earmv6hfglimpse-4.18.6.tgz
NetBSD 9.0earmv6hfglimpse-4.18.6.tgz
NetBSD 9.0earmv7hfglimpse-4.18.6.tgz
NetBSD 9.0earmv7hfglimpse-4.18.6.tgz
NetBSD 9.0earmv7hfglimpse-4.18.6.tgz
NetBSD 9.0earmv7hfglimpse-4.18.6.tgz
NetBSD 9.0i386glimpse-4.18.6.tgz
NetBSD 9.0i386glimpse-4.18.6.tgz
NetBSD 9.0mips64ebglimpse-4.18.6.tgz
NetBSD 9.0mips64ebglimpse-4.18.6.tgz
NetBSD 9.0mips64ebglimpse-4.18.6.tgz
NetBSD 9.0mips64ebglimpse-4.18.6.tgz
NetBSD 9.0mips64ebglimpse-4.18.6.tgz
NetBSD 9.0powerpcglimpse-4.18.6.tgz
NetBSD 9.0powerpcglimpse-4.18.6.tgz
NetBSD 9.0powerpcglimpse-4.18.6.tgz
NetBSD 9.0powerpcglimpse-4.18.6.tgz
NetBSD 9.0sh3elglimpse-4.18.6.tgz
NetBSD 9.0sh3elglimpse-4.18.6.tgz
NetBSD 9.0sh3elglimpse-4.18.6.tgz
NetBSD 9.0sparc64glimpse-4.18.6.tgz
NetBSD 9.0sparc64glimpse-4.18.6.tgz
NetBSD 9.0sparc64glimpse-4.18.6.tgz
NetBSD 9.0sparcglimpse-4.18.6.tgz
NetBSD 9.0sparcglimpse-4.18.6.tgz
NetBSD 9.0sparcglimpse-4.18.6.tgz
NetBSD 9.0sparcglimpse-4.18.6.tgz
NetBSD 9.0sparcglimpse-4.18.6.tgz
NetBSD 9.0vaxglimpse-4.18.6.tgz
NetBSD 9.0vaxglimpse-4.18.6.tgz
NetBSD 9.0x86_64glimpse-4.18.6.tgz
NetBSD 9.0x86_64glimpse-4.18.6.tgz
NetBSD 9.0x86_64glimpse-4.18.6.tgz
NetBSD 9.0x86_64glimpse-4.18.6.tgz
NetBSD 9.0x86_64glimpse-4.18.6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.