textproc/ansifilter - The NetBSD Packages Collection

Converts text containing terminal escape codes into markup

Ansifilter converts text containing ANSI terminal escape codes into
markup (HTML, LaTeX, TeX, RTF) or plaintext (stripping the escape codes).
Such text is produced for instance by the script(1) utility.
Colors, boldface, underline, italic and blink are supported.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfansifilter-2.18.tgz
NetBSD 8.0earmv7hfansifilter-1.15.tgz
NetBSD 8.0earmv7hfansifilter-1.15.tgz
NetBSD 8.0i386ansifilter-1.15.tgz
NetBSD 8.0i386ansifilter-1.15.tgz
NetBSD 8.0powerpcansifilter-1.15.tgz
NetBSD 8.0powerpcansifilter-1.15.tgz
NetBSD 8.0powerpcansifilter-1.15.tgz
NetBSD 8.0powerpcansifilter-2.18.tgz
NetBSD 8.0x86_64ansifilter-1.15.tgz
NetBSD 8.0x86_64ansifilter-1.15.tgz
NetBSD 9.0aarch64ansifilter-2.18.tgz
NetBSD 9.0aarch64ansifilter-1.15.tgz
NetBSD 9.0aarch64ansifilter-1.15.tgz
NetBSD 9.0alphaansifilter-2.18.tgz
NetBSD 9.0alphaansifilter-1.15.tgz
NetBSD 9.0alphaansifilter-1.15.tgz
NetBSD 9.0earmansifilter-1.15.tgz
NetBSD 9.0earmansifilter-1.15.tgz
NetBSD 9.0earmv6hfansifilter-2.18.tgz
NetBSD 9.0earmv6hfansifilter-1.15.tgz
NetBSD 9.0earmv6hfansifilter-1.15.tgz
NetBSD 9.0earmv7hfansifilter-2.18.tgz
NetBSD 9.0earmv7hfansifilter-1.15.tgz
NetBSD 9.0earmv7hfansifilter-1.15.tgz
NetBSD 9.0earmv7hfansifilter-2.18.tgz
NetBSD 9.0i386ansifilter-1.15.tgz
NetBSD 9.0i386ansifilter-1.15.tgz
NetBSD 9.0m68kansifilter-1.15.tgz
NetBSD 9.0mips64ebansifilter-1.15.tgz
NetBSD 9.0mips64ebansifilter-1.15.tgz
NetBSD 9.0mips64ebansifilter-1.15.tgz
NetBSD 9.0mips64ebansifilter-1.15.tgz
NetBSD 9.0mips64ebansifilter-2.18.tgz
NetBSD 9.0powerpcansifilter-1.15.tgz
NetBSD 9.0powerpcansifilter-1.15.tgz
NetBSD 9.0powerpcansifilter-1.15.tgz
NetBSD 9.0powerpcansifilter-1.15.tgz
NetBSD 9.0powerpcansifilter-2.18.tgz
NetBSD 9.0sparc64ansifilter-1.15.tgz
NetBSD 9.0sparc64ansifilter-1.15.tgz
NetBSD 9.0sparc64ansifilter-2.18.tgz
NetBSD 9.0sparcansifilter-1.15.tgz
NetBSD 9.0sparcansifilter-1.15.tgz
NetBSD 9.0sparcansifilter-1.15.tgz
NetBSD 9.0x86_64ansifilter-2.18.tgz
NetBSD 9.0x86_64ansifilter-2.18.tgz
NetBSD 9.0x86_64ansifilter-1.15.tgz
NetBSD 9.0x86_64ansifilter-1.15.tgz
NetBSD 9.0x86_64ansifilter-2.18.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.