sysutils/mate-power-manager - The NetBSD Packages Collection

Power manager for MATE

MATE Power Manager is a MATE session daemon that acts as a policy agent on top
of UPower, which requires fairly new versions of the kernel and udev.
MATE Power Manager listens for system events and responds with user-
configurable actions.

MATE Power Manager is a fork of GNOME Power Manager.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers textproc/py-libxml2 devel/glib2-tools textproc/libxml2 security/polkit devel/libtool-base devel/gmake textproc/itstool devel/gettext-tools devel/pkgconf

Runtime dependencies

lang/python39 lang/python39 x11/gtk3 devel/glib2 sysutils/dbus sysutils/desktop-file-utils sysutils/upower x11/mate-desktop x11/mate-panel audio/libcanberra graphics/hicolor-icon-theme sysutils/dbus-glib sysutils/libnotify x11/libunique x11/gtk3 devel/glib2 sysutils/desktop-file-utils sysutils/upower x11/mate-panel audio/libcanberra graphics/hicolor-icon-theme sysutils/dbus-glib sysutils/libnotify x11/libunique

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmate-power-manager-1.24.3.tgz
NetBSD 8.0x86_64mate-power-manager-1.24.1nb3.tgz
NetBSD 8.0x86_64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0aarch64mate-power-manager-1.24.3.tgz
NetBSD 9.0aarch64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0aarch64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0alphamate-power-manager-1.24.3.tgz
NetBSD 9.0earmv6hfmate-power-manager-1.24.3.tgz
NetBSD 9.0earmv7hfmate-power-manager-1.24.3.tgz
NetBSD 9.0earmv7hfmate-power-manager-1.24.3.tgz
NetBSD 9.0i386mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0sparc64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0sparc64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0sparc64mate-power-manager-1.24.3.tgz
NetBSD 9.0x86_64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0x86_64mate-power-manager-1.24.3.tgz
NetBSD 9.0x86_64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0x86_64mate-power-manager-1.24.1nb3.tgz
NetBSD 9.0x86_64mate-power-manager-1.24.3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.