sysutils/libnotify - The NetBSD Packages Collection

Desktop notification framework

libnotify is a library that allows applications to raise visual notifications
in a desktop environment.  An external application, the notification-daemon,
is then in charge to show them as it wishes.

Build dependencies

pkgtools/x11-links devel/gobject-introspection x11/gtk3 x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/gobject-introspection x11/gtk3 textproc/docbook-xsl textproc/libxslt devel/glib2-tools devel/meson lang/python38 devel/pkgconf

Runtime dependencies

devel/glib2 devel/glib2 graphics/gdk-pixbuf2 devel/glib2 graphics/gdk-pixbuf2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibnotify-0.7.9nb3.tgz
NetBSD 8.0earmv7hflibnotify-0.7.9nb3.tgz
NetBSD 8.0earmv7hflibnotify-0.7.9nb3.tgz
NetBSD 8.0i386libnotify-0.7.9nb3.tgz
NetBSD 8.0i386libnotify-0.7.9nb3.tgz
NetBSD 8.0i386libnotify-0.7.9nb3.tgz
NetBSD 8.0powerpclibnotify-0.7.9nb3.tgz
NetBSD 8.0powerpclibnotify-0.7.9nb3.tgz
NetBSD 8.0powerpclibnotify-0.7.9nb3.tgz
NetBSD 8.0x86_64libnotify-0.7.9nb3.tgz
NetBSD 8.0x86_64libnotify-0.7.9nb3.tgz
NetBSD 9.0aarch64libnotify-0.7.9nb3.tgz
NetBSD 9.0aarch64libnotify-0.7.9nb3.tgz
NetBSD 9.0aarch64libnotify-0.7.9nb3.tgz
NetBSD 9.0alphalibnotify-0.7.9nb3.tgz
NetBSD 9.0alphalibnotify-0.7.9nb3.tgz
NetBSD 9.0alphalibnotify-0.7.9nb3.tgz
NetBSD 9.0earmlibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv6hflibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv6hflibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv6hflibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv6hflibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv7hflibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv7hflibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv7hflibnotify-0.7.9nb3.tgz
NetBSD 9.0earmv7hflibnotify-0.7.9nb3.tgz
NetBSD 9.0i386libnotify-0.7.9nb3.tgz
NetBSD 9.0i386libnotify-0.7.9nb3.tgz
NetBSD 9.0m68klibnotify-0.7.9nb3.tgz
NetBSD 9.0m68klibnotify-0.7.9nb3.tgz
NetBSD 9.0mips64eblibnotify-0.7.9nb3.tgz
NetBSD 9.0mips64eblibnotify-0.7.9nb3.tgz
NetBSD 9.0mips64eblibnotify-0.7.9nb3.tgz
NetBSD 9.0powerpclibnotify-0.7.9nb3.tgz
NetBSD 9.0powerpclibnotify-0.7.9nb3.tgz
NetBSD 9.0sh3ellibnotify-0.7.9nb3.tgz
NetBSD 9.0sh3ellibnotify-0.7.9nb3.tgz
NetBSD 9.0sparc64libnotify-0.7.9nb3.tgz
NetBSD 9.0sparc64libnotify-0.7.9nb2.tgz
NetBSD 9.0sparc64libnotify-0.7.9nb3.tgz
NetBSD 9.0sparc64libnotify-0.7.9nb3.tgz
NetBSD 9.0sparclibnotify-0.7.9nb3.tgz
NetBSD 9.0sparclibnotify-0.7.9nb3.tgz
NetBSD 9.0sparclibnotify-0.7.9nb3.tgz
NetBSD 9.0x86_64libnotify-0.7.9nb3.tgz
NetBSD 9.0x86_64libnotify-0.7.9nb3.tgz
NetBSD 9.0x86_64libnotify-0.7.9nb3.tgz
NetBSD 9.0x86_64libnotify-0.7.9nb3.tgz
NetBSD 9.0x86_64libnotify-0.7.9nb3.tgz
NetBSD 9.0x86_64libnotify-0.7.9nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

doc
Include the documentation.
introspection
Enable GObject Introspection support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.