sysutils/liblognorm - The NetBSD Packages Collection

Tool to normalize log data

liblognorm shall help to make sense out of syslog data, or, actually,
any event data that is present in text form.

In short words, one will be able to throw arbitrary log message to
liblognorm, one at a time, and for each message it will output
well-defined name-value pairs and a set of tags describing the message.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

textproc/libfastjson devel/libestr

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfliblognorm-2.0.6.tgz
NetBSD 8.0earmv7hfliblognorm-2.0.6.tgz
NetBSD 8.0earmv7hfliblognorm-2.0.6.tgz
NetBSD 8.0i386liblognorm-2.0.6.tgz
NetBSD 8.0i386liblognorm-2.0.6.tgz
NetBSD 8.0powerpcliblognorm-2.0.6.tgz
NetBSD 8.0powerpcliblognorm-2.0.6.tgz
NetBSD 8.0powerpcliblognorm-2.0.6.tgz
NetBSD 8.0powerpcliblognorm-2.0.6.tgz
NetBSD 8.0x86_64liblognorm-2.0.6.tgz
NetBSD 8.0x86_64liblognorm-2.0.6.tgz
NetBSD 9.0aarch64liblognorm-2.0.6.tgz
NetBSD 9.0aarch64liblognorm-2.0.6.tgz
NetBSD 9.0aarch64liblognorm-2.0.6.tgz
NetBSD 9.0alphaliblognorm-2.0.6.tgz
NetBSD 9.0alphaliblognorm-2.0.6.tgz
NetBSD 9.0alphaliblognorm-2.0.6.tgz
NetBSD 9.0earmliblognorm-2.0.6.tgz
NetBSD 9.0earmliblognorm-2.0.6.tgz
NetBSD 9.0earmliblognorm-2.0.6.tgz
NetBSD 9.0earmv6hfliblognorm-2.0.6.tgz
NetBSD 9.0earmv6hfliblognorm-2.0.6.tgz
NetBSD 9.0earmv6hfliblognorm-2.0.6.tgz
NetBSD 9.0earmv7hfliblognorm-2.0.6.tgz
NetBSD 9.0earmv7hfliblognorm-2.0.6.tgz
NetBSD 9.0earmv7hfliblognorm-2.0.6.tgz
NetBSD 9.0earmv7hfliblognorm-2.0.6.tgz
NetBSD 9.0i386liblognorm-2.0.6.tgz
NetBSD 9.0i386liblognorm-2.0.6.tgz
NetBSD 9.0m68kliblognorm-2.0.6.tgz
NetBSD 9.0m68kliblognorm-2.0.6.tgz
NetBSD 9.0m68kliblognorm-2.0.6.tgz
NetBSD 9.0mips64ebliblognorm-2.0.6.tgz
NetBSD 9.0mips64ebliblognorm-2.0.6.tgz
NetBSD 9.0mips64ebliblognorm-2.0.6.tgz
NetBSD 9.0mips64ebliblognorm-2.0.6.tgz
NetBSD 9.0mips64ebliblognorm-2.0.6.tgz
NetBSD 9.0mipselliblognorm-2.0.6.tgz
NetBSD 9.0mipselliblognorm-2.0.6.tgz
NetBSD 9.0mipselliblognorm-2.0.6.tgz
NetBSD 9.0mipselliblognorm-2.0.6.tgz
NetBSD 9.0powerpcliblognorm-2.0.6.tgz
NetBSD 9.0powerpcliblognorm-2.0.6.tgz
NetBSD 9.0powerpcliblognorm-2.0.6.tgz
NetBSD 9.0powerpcliblognorm-2.0.6.tgz
NetBSD 9.0sh3elliblognorm-2.0.6.tgz
NetBSD 9.0sh3elliblognorm-2.0.6.tgz
NetBSD 9.0sh3elliblognorm-2.0.6.tgz
NetBSD 9.0sh3elliblognorm-2.0.6.tgz
NetBSD 9.0sh3elliblognorm-2.0.6.tgz
NetBSD 9.0sparc64liblognorm-2.0.6.tgz
NetBSD 9.0sparc64liblognorm-2.0.6.tgz
NetBSD 9.0sparc64liblognorm-2.0.6.tgz
NetBSD 9.0sparcliblognorm-2.0.6.tgz
NetBSD 9.0sparcliblognorm-2.0.6.tgz
NetBSD 9.0sparcliblognorm-2.0.6.tgz
NetBSD 9.0sparcliblognorm-2.0.6.tgz
NetBSD 9.0sparcliblognorm-2.0.6.tgz
NetBSD 9.0vaxliblognorm-2.0.6.tgz
NetBSD 9.0vaxliblognorm-2.0.6.tgz
NetBSD 9.0vaxliblognorm-2.0.6.tgz
NetBSD 9.0vaxliblognorm-2.0.6.tgz
NetBSD 9.0x86_64liblognorm-2.0.6.tgz
NetBSD 9.0x86_64liblognorm-2.0.6.tgz
NetBSD 9.0x86_64liblognorm-2.0.6.tgz
NetBSD 9.0x86_64liblognorm-2.0.6.tgz
NetBSD 9.0x86_64liblognorm-2.0.6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.