sysutils/cfengine3 - The NetBSD Packages Collection

Tool for automating system administration

Cfengine, or the "configuration engine" is a very high level language
for building expert systems which administrate and configure large
computer networks. Cfengine uses the idea of classes and a primitive
form of intelligence to define and automate the configuration of
large systems in the most economical way possible. Cfengine is
designed to be a part of computer immune system.

Cfengine 3 is operationally backwards compatible with Cfengine 2, but the
language is not. Cfengine 3 is not a drop-in replacement for Cfengine 2.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

databases/tokyocabinet devel/pcre textproc/libxml2 textproc/libyaml www/curl databases/tokyocabinet devel/pcre textproc/libxml2 textproc/libyaml www/curl

Available binary packages

aarch64:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
aarch64:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
aarch64:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
alpha:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
alpha:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
earmv6hf:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
earmv6hf:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
earmv6hf:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
earmv6hf:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
earmv7hf:cfengine-3.15.2nb1.tgz(NetBSD 8.0)
earmv7hf:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
earmv7hf:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
earmv7hf:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
earmv7hf:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
earmv7hf:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
earmv7hf:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
i386:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
i386:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
i386:cfengine-3.15.2nb1.tgz(NetBSD 8.0)
i386:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
i386:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
i386:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
mips64eb:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
powerpc:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
powerpc:cfengine-3.15.2nb1.tgz(NetBSD 8.0)
powerpc:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
powerpc:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
powerpc:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
sparc64:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
sparc64:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
x86_64:cfengine-3.15.1nb3.tgz(NetBSD 8.0)
x86_64:cfengine-3.15.2nb1.tgz(NetBSD 8.0)
x86_64:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.1nb3.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.2nb1.tgz(NetBSD 9.0)
x86_64:cfengine-3.15.2nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

mysql
Enable MySQL support.
pgsql
Enable PostgreSQL support.
lmdb
Enable lmdb support.
qdbm
Enable qdbm support.
tokyocabinet
Enable Tokyo Cabinet support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]