security/volatility - The NetBSD Packages Collection

Advanced memory forensics framework

The Volatility Framework is a completely open collection of tools,
implemented in Python under the GNU General Public License, for the
extraction of digital artifacts from volatile memory (RAM) samples.
The extraction techniques are performed completely independent of the
system being investigated but offer visibilty into the runtime state
of the system. The framework is intended to introduce people to the
techniques and complexities associated with extracting digital artifacts
from volatile memory samples and provide a platform for further work into
this exciting area of research.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

databases/py-sqlite3 graphics/py-Pillow6 security/py-cryptodome textproc/py-cElementTree devel/py-distorm3 textproc/py-openpyxl security/py-yara devel/py-setuptools44 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfvolatility-2.6.1.tgz
NetBSD 8.0earmv7hfvolatility-2.6.1.tgz
NetBSD 8.0earmv7hfvolatility-2.6.1.tgz
NetBSD 8.0i386volatility-2.6.1.tgz
NetBSD 8.0i386volatility-2.6.1.tgz
NetBSD 8.0x86_64volatility-2.6.1.tgz
NetBSD 8.0x86_64volatility-2.6.1.tgz
NetBSD 9.0aarch64volatility-2.6.1.tgz
NetBSD 9.0aarch64volatility-2.6.1.tgz
NetBSD 9.0aarch64volatility-2.6.1.tgz
NetBSD 9.0alphavolatility-2.6.1.tgz
NetBSD 9.0alphavolatility-2.6.1.tgz
NetBSD 9.0alphavolatility-2.6.1.tgz
NetBSD 9.0earmv6hfvolatility-2.6.1.tgz
NetBSD 9.0earmv6hfvolatility-2.6.1.tgz
NetBSD 9.0earmv6hfvolatility-2.6.1.tgz
NetBSD 9.0earmv7hfvolatility-2.6.1.tgz
NetBSD 9.0earmv7hfvolatility-2.6.1.tgz
NetBSD 9.0earmv7hfvolatility-2.6.1.tgz
NetBSD 9.0earmv7hfvolatility-2.6.1.tgz
NetBSD 9.0i386volatility-2.6.1.tgz
NetBSD 9.0i386volatility-2.6.1.tgz
NetBSD 9.0i386volatility-2.6.1.tgz
NetBSD 9.0mips64ebvolatility-2.6.1.tgz
NetBSD 9.0mips64ebvolatility-2.4nb1.tgz
NetBSD 9.0mips64ebvolatility-2.4nb1.tgz
NetBSD 9.0mips64ebvolatility-2.6.1.tgz
NetBSD 9.0mips64ebvolatility-2.6.1.tgz
NetBSD 9.0sparc64volatility-2.6.1.tgz
NetBSD 9.0sparc64volatility-2.6.1.tgz
NetBSD 9.0sparc64volatility-2.6.1.tgz
NetBSD 9.0sparcvolatility-2.6.1.tgz
NetBSD 9.0sparcvolatility-2.6.1.tgz
NetBSD 9.0sparcvolatility-2.6.1.tgz
NetBSD 9.0x86_64volatility-2.6.1.tgz
NetBSD 9.0x86_64volatility-2.6.1.tgz
NetBSD 9.0x86_64volatility-2.6.1.tgz
NetBSD 9.0x86_64volatility-2.6.1.tgz
NetBSD 9.0x86_64volatility-2.6.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.