security/srm - The NetBSD Packages Collection

Secure replacement for rm(1)

Srm is a secure replacement for rm(1).  Unlike the standard rm, it overwrites
the data in the target files before unlinkg them.  This prevents command-line
recovery of the data by examining the raw block device.  It may also help
frustrate physical examination of the disk, although it's unlikely that
completely protects against this type of recovery.

Srm uses algorithms found in _Secure Deletion of Data from Magnetic and
Solid-State Memory_ by Peter Gutmann and THC Secure Delete (the overwrite,
truncate, rename, unlink sequence).

All users, but especially Linux users, should be aware that srm will only
work on file systems that overwrite blocks in place.  In particular, it will
_NOT_ work on resiserfs or the vast majority of journaled file systems.  It
should work on ext2, FAT-based file systems, and the BSD native file system.
Ext3 users should be especially careful as it can be set to journal data as
well, which is an obvious route to reconstructing information.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsrm-1.2.15.tgz
NetBSD 8.0earmv7hfsrm-1.2.15.tgz
NetBSD 8.0earmv7hfsrm-1.2.15.tgz
NetBSD 8.0i386srm-1.2.15.tgz
NetBSD 8.0i386srm-1.2.15.tgz
NetBSD 8.0powerpcsrm-1.2.15.tgz
NetBSD 8.0powerpcsrm-1.2.15.tgz
NetBSD 8.0powerpcsrm-1.2.15.tgz
NetBSD 8.0powerpcsrm-1.2.15.tgz
NetBSD 8.0x86_64srm-1.2.15.tgz
NetBSD 8.0x86_64srm-1.2.15.tgz
NetBSD 9.0aarch64srm-1.2.15.tgz
NetBSD 9.0aarch64srm-1.2.15.tgz
NetBSD 9.0aarch64srm-1.2.15.tgz
NetBSD 9.0alphasrm-1.2.15.tgz
NetBSD 9.0alphasrm-1.2.15.tgz
NetBSD 9.0alphasrm-1.2.15.tgz
NetBSD 9.0earmsrm-1.2.15.tgz
NetBSD 9.0earmsrm-1.2.15.tgz
NetBSD 9.0earmsrm-1.2.15.tgz
NetBSD 9.0earmv6hfsrm-1.2.15.tgz
NetBSD 9.0earmv6hfsrm-1.2.15.tgz
NetBSD 9.0earmv6hfsrm-1.2.15.tgz
NetBSD 9.0earmv7hfsrm-1.2.15.tgz
NetBSD 9.0earmv7hfsrm-1.2.15.tgz
NetBSD 9.0earmv7hfsrm-1.2.15.tgz
NetBSD 9.0earmv7hfsrm-1.2.15.tgz
NetBSD 9.0i386srm-1.2.15.tgz
NetBSD 9.0i386srm-1.2.15.tgz
NetBSD 9.0i386srm-1.2.15.tgz
NetBSD 9.0m68ksrm-1.2.15.tgz
NetBSD 9.0m68ksrm-1.2.15.tgz
NetBSD 9.0mips64ebsrm-1.2.15.tgz
NetBSD 9.0mips64ebsrm-1.2.15.tgz
NetBSD 9.0mips64ebsrm-1.2.15.tgz
NetBSD 9.0mips64ebsrm-1.2.15.tgz
NetBSD 9.0mips64ebsrm-1.2.15.tgz
NetBSD 9.0powerpcsrm-1.2.15.tgz
NetBSD 9.0powerpcsrm-1.2.15.tgz
NetBSD 9.0powerpcsrm-1.2.15.tgz
NetBSD 9.0powerpcsrm-1.2.15.tgz
NetBSD 9.0sparc64srm-1.2.15.tgz
NetBSD 9.0sparc64srm-1.2.15.tgz
NetBSD 9.0sparc64srm-1.2.15.tgz
NetBSD 9.0sparcsrm-1.2.15.tgz
NetBSD 9.0sparcsrm-1.2.15.tgz
NetBSD 9.0sparcsrm-1.2.15.tgz
NetBSD 9.0sparcsrm-1.2.15.tgz
NetBSD 9.0x86_64srm-1.2.15.tgz
NetBSD 9.0x86_64srm-1.2.15.tgz
NetBSD 9.0x86_64srm-1.2.15.tgz
NetBSD 9.0x86_64srm-1.2.15.tgz
NetBSD 9.0x86_64srm-1.2.15.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.