security/sqlmap - The NetBSD Packages Collection

Automatic SQL injection and database takeover tool

sqlmap is an open source penetration testing tool that automates
the process of detecting and exploiting SQL injection flaws and
taking over of database servers. It comes with a powerful detection
engine, many niche features for the ultimate penetration tester
and a broad range of switches lasting from database fingerprinting,
over data fetching from the database, to accessing the underlying
file system and executing commands on the operating system via
out-of-band connections.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

databases/py-sqlite3 devel/py-setuptools shells/bash lang/perl5 lang/python39 lang/python39

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsqlmap-1.5.4nb1.tgz
NetBSD 8.0earmv7hfsqlmap-1.5.3.tgz
NetBSD 8.0earmv7hfsqlmap-1.5.4nb1.tgz
NetBSD 8.0i386sqlmap-1.5.3.tgz
NetBSD 8.0i386sqlmap-1.5.4nb1.tgz
NetBSD 8.0powerpcsqlmap-1.5.3.tgz
NetBSD 8.0powerpcsqlmap-1.5.4nb1.tgz
NetBSD 8.0powerpcsqlmap-1.5.4nb1.tgz
NetBSD 8.0powerpcsqlmap-1.5.4nb1.tgz
NetBSD 8.0x86_64sqlmap-1.5.3.tgz
NetBSD 8.0x86_64sqlmap-1.5.4nb1.tgz
NetBSD 9.0aarch64sqlmap-1.5.4nb1.tgz
NetBSD 9.0aarch64sqlmap-1.5.3.tgz
NetBSD 9.0aarch64sqlmap-1.5.4nb1.tgz
NetBSD 9.0alphasqlmap-1.5.4nb1.tgz
NetBSD 9.0alphasqlmap-1.5.3.tgz
NetBSD 9.0alphasqlmap-1.5.4nb1.tgz
NetBSD 9.0earmv6hfsqlmap-1.5.4nb1.tgz
NetBSD 9.0earmv6hfsqlmap-1.5.3.tgz
NetBSD 9.0earmv6hfsqlmap-1.5.4nb1.tgz
NetBSD 9.0earmv7hfsqlmap-1.5.4nb1.tgz
NetBSD 9.0earmv7hfsqlmap-1.5.3.tgz
NetBSD 9.0earmv7hfsqlmap-1.5.4nb1.tgz
NetBSD 9.0earmv7hfsqlmap-1.5.4nb1.tgz
NetBSD 9.0i386sqlmap-1.5.3.tgz
NetBSD 9.0i386sqlmap-1.5.4nb1.tgz
NetBSD 9.0mips64ebsqlmap-1.5.4nb1.tgz
NetBSD 9.0mips64ebsqlmap-1.4.9.tgz
NetBSD 9.0mips64ebsqlmap-1.4.10nb1.tgz
NetBSD 9.0mips64ebsqlmap-1.5.3.tgz
NetBSD 9.0mips64ebsqlmap-1.5.4nb1.tgz
NetBSD 9.0powerpcsqlmap-1.5.4nb1.tgz
NetBSD 9.0powerpcsqlmap-1.5.3.tgz
NetBSD 9.0powerpcsqlmap-1.5.4nb1.tgz
NetBSD 9.0powerpcsqlmap-1.5.4nb1.tgz
NetBSD 9.0sparc64sqlmap-1.5.4nb1.tgz
NetBSD 9.0sparc64sqlmap-1.5.3.tgz
NetBSD 9.0sparc64sqlmap-1.5.4nb1.tgz
NetBSD 9.0sparcsqlmap-1.5.4nb1.tgz
NetBSD 9.0sparcsqlmap-1.4.9.tgz
NetBSD 9.0sparcsqlmap-1.5.3.tgz
NetBSD 9.0sparcsqlmap-1.5.4nb1.tgz
NetBSD 9.0x86_64sqlmap-1.5.4nb1.tgz
NetBSD 9.0x86_64sqlmap-1.5.4nb1.tgz
NetBSD 9.0x86_64sqlmap-1.5.3.tgz
NetBSD 9.0x86_64sqlmap-1.5.4nb1.tgz
NetBSD 9.0x86_64sqlmap-1.5.4nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.