security/py-yubiauth - The NetBSD Packages Collection

YubiAuth authentication backend

YubiAuth provides a user management system which can be used as a
base for other systems. It allows the creation of users, which can
be authenticated by username, password, and optionally a YubiKey
OTP.
Aside from providing a user authentication backend, YubiAuth allows
storing and retrieving arbitrary key-value attributes for each user
as well as each YubiKey.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

devel/py-setuptools44 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-yubiauth-0.3.9.tgz
NetBSD 8.0earmv7hfpy27-yubiauth-0.3.9.tgz
NetBSD 8.0earmv7hfpy27-yubiauth-0.3.9.tgz
NetBSD 8.0i386py27-yubiauth-0.3.9.tgz
NetBSD 8.0i386py27-yubiauth-0.3.9.tgz
NetBSD 8.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 8.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 8.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 8.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 8.0x86_64py27-yubiauth-0.3.9.tgz
NetBSD 8.0x86_64py27-yubiauth-0.3.9.tgz
NetBSD 9.0aarch64py27-yubiauth-0.3.9.tgz
NetBSD 9.0aarch64py27-yubiauth-0.3.9.tgz
NetBSD 9.0aarch64py27-yubiauth-0.3.9.tgz
NetBSD 9.0alphapy27-yubiauth-0.3.9.tgz
NetBSD 9.0alphapy27-yubiauth-0.3.9.tgz
NetBSD 9.0alphapy27-yubiauth-0.3.9.tgz
NetBSD 9.0earmv6hfpy27-yubiauth-0.3.9.tgz
NetBSD 9.0earmv6hfpy27-yubiauth-0.3.9.tgz
NetBSD 9.0earmv6hfpy27-yubiauth-0.3.9.tgz
NetBSD 9.0earmv7hfpy27-yubiauth-0.3.9.tgz
NetBSD 9.0earmv7hfpy27-yubiauth-0.3.9.tgz
NetBSD 9.0earmv7hfpy27-yubiauth-0.3.9.tgz
NetBSD 9.0earmv7hfpy27-yubiauth-0.3.9.tgz
NetBSD 9.0i386py27-yubiauth-0.3.9.tgz
NetBSD 9.0i386py27-yubiauth-0.3.9.tgz
NetBSD 9.0i386py27-yubiauth-0.3.9.tgz
NetBSD 9.0mips64ebpy27-yubiauth-0.3.9.tgz
NetBSD 9.0mips64ebpy27-yubiauth-0.3.9.tgz
NetBSD 9.0mips64ebpy27-yubiauth-0.3.9.tgz
NetBSD 9.0mips64ebpy27-yubiauth-0.3.9.tgz
NetBSD 9.0mips64ebpy27-yubiauth-0.3.9.tgz
NetBSD 9.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0powerpcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0sparc64py27-yubiauth-0.3.9.tgz
NetBSD 9.0sparc64py27-yubiauth-0.3.9.tgz
NetBSD 9.0sparc64py27-yubiauth-0.3.9.tgz
NetBSD 9.0sparcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0sparcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0sparcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0sparcpy27-yubiauth-0.3.9.tgz
NetBSD 9.0x86_64py27-yubiauth-0.3.9.tgz
NetBSD 9.0x86_64py27-yubiauth-0.3.9.tgz
NetBSD 9.0x86_64py27-yubiauth-0.3.9.tgz
NetBSD 9.0x86_64py27-yubiauth-0.3.9.tgz
NetBSD 9.0x86_64py27-yubiauth-0.3.9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.