security/py-trustme - The NetBSD Packages Collection

Number on quality TLS certs while you wait

trustme is a tiny Python package that does one thing: it gives you a fake
certificate authority (CA) that you can use to generate fake TLS certs to use
in your tests. Well, technically they're real certs, they're just signed by
your CA, which nobody trusts. But you can trust it. Trust me.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

security/py-cryptography www/py-idna devel/py-setuptools lang/python38 lang/python38

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy36-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy38-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy39-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy27-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy36-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy38-trustme-0.6.0.tgz
NetBSD 8.0earmv7hfpy39-trustme-0.6.0.tgz
NetBSD 8.0i386py27-trustme-0.6.0.tgz
NetBSD 8.0i386py36-trustme-0.6.0.tgz
NetBSD 8.0i386py37-trustme-0.6.0.tgz
NetBSD 8.0i386py38-trustme-0.6.0.tgz
NetBSD 8.0i386py27-trustme-0.6.0.tgz
NetBSD 8.0i386py36-trustme-0.6.0.tgz
NetBSD 8.0i386py37-trustme-0.6.0.tgz
NetBSD 8.0i386py38-trustme-0.6.0.tgz
NetBSD 8.0i386py39-trustme-0.6.0.tgz
NetBSD 8.0i386py27-trustme-0.6.0.tgz
NetBSD 8.0i386py36-trustme-0.6.0.tgz
NetBSD 8.0i386py37-trustme-0.6.0.tgz
NetBSD 8.0i386py38-trustme-0.6.0.tgz
NetBSD 8.0i386py39-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy39-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy39-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 8.0powerpcpy39-trustme-0.6.0.tgz
NetBSD 8.0x86_64py27-trustme-0.6.0.tgz
NetBSD 8.0x86_64py36-trustme-0.6.0.tgz
NetBSD 8.0x86_64py37-trustme-0.6.0.tgz
NetBSD 8.0x86_64py38-trustme-0.6.0.tgz
NetBSD 8.0x86_64py39-trustme-0.6.0.tgz
NetBSD 8.0x86_64py27-trustme-0.6.0.tgz
NetBSD 8.0x86_64py36-trustme-0.6.0.tgz
NetBSD 8.0x86_64py37-trustme-0.6.0.tgz
NetBSD 8.0x86_64py38-trustme-0.6.0.tgz
NetBSD 8.0x86_64py27-trustme-0.6.0.tgz
NetBSD 8.0x86_64py36-trustme-0.6.0.tgz
NetBSD 8.0x86_64py37-trustme-0.6.0.tgz
NetBSD 8.0x86_64py38-trustme-0.6.0.tgz
NetBSD 8.0x86_64py39-trustme-0.6.0.tgz
NetBSD 9.0aarch64py27-trustme-0.6.0.tgz
NetBSD 9.0aarch64py36-trustme-0.6.0.tgz
NetBSD 9.0aarch64py37-trustme-0.6.0.tgz
NetBSD 9.0aarch64py38-trustme-0.6.0.tgz
NetBSD 9.0aarch64py39-trustme-0.6.0.tgz
NetBSD 9.0aarch64py27-trustme-0.6.0.tgz
NetBSD 9.0aarch64py36-trustme-0.6.0.tgz
NetBSD 9.0aarch64py37-trustme-0.6.0.tgz
NetBSD 9.0aarch64py38-trustme-0.6.0.tgz
NetBSD 9.0aarch64py27-trustme-0.6.0.tgz
NetBSD 9.0aarch64py36-trustme-0.6.0.tgz
NetBSD 9.0aarch64py37-trustme-0.6.0.tgz
NetBSD 9.0aarch64py38-trustme-0.6.0.tgz
NetBSD 9.0aarch64py39-trustme-0.6.0.tgz
NetBSD 9.0alphapy27-trustme-0.6.0.tgz
NetBSD 9.0alphapy36-trustme-0.6.0.tgz
NetBSD 9.0alphapy37-trustme-0.6.0.tgz
NetBSD 9.0alphapy38-trustme-0.6.0.tgz
NetBSD 9.0alphapy39-trustme-0.6.0.tgz
NetBSD 9.0alphapy27-trustme-0.6.0.tgz
NetBSD 9.0alphapy36-trustme-0.6.0.tgz
NetBSD 9.0alphapy37-trustme-0.6.0.tgz
NetBSD 9.0alphapy38-trustme-0.6.0.tgz
NetBSD 9.0alphapy27-trustme-0.6.0.tgz
NetBSD 9.0alphapy36-trustme-0.6.0.tgz
NetBSD 9.0alphapy37-trustme-0.6.0.tgz
NetBSD 9.0alphapy38-trustme-0.6.0.tgz
NetBSD 9.0alphapy39-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy39-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy39-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv6hfpy39-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy39-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy39-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy39-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy27-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy36-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy37-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy38-trustme-0.6.0.tgz
NetBSD 9.0earmv7hfpy39-trustme-0.6.0.tgz
NetBSD 9.0i386py27-trustme-0.6.0.tgz
NetBSD 9.0i386py36-trustme-0.6.0.tgz
NetBSD 9.0i386py37-trustme-0.6.0.tgz
NetBSD 9.0i386py38-trustme-0.6.0.tgz
NetBSD 9.0i386py27-trustme-0.6.0.tgz
NetBSD 9.0i386py36-trustme-0.6.0.tgz
NetBSD 9.0i386py37-trustme-0.6.0.tgz
NetBSD 9.0i386py38-trustme-0.6.0.tgz
NetBSD 9.0i386py39-trustme-0.6.0.tgz
NetBSD 9.0i386py27-trustme-0.6.0.tgz
NetBSD 9.0i386py36-trustme-0.6.0.tgz
NetBSD 9.0i386py37-trustme-0.6.0.tgz
NetBSD 9.0i386py38-trustme-0.6.0.tgz
NetBSD 9.0i386py39-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy27-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy36-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy37-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy38-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy39-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy27-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy36-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy37-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy38-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy27-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy36-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy37-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy38-trustme-0.6.0.tgz
NetBSD 9.0mips64ebpy39-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy39-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy39-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy27-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy36-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy37-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy38-trustme-0.6.0.tgz
NetBSD 9.0powerpcpy39-trustme-0.6.0.tgz
NetBSD 9.0sparc64py27-trustme-0.6.0.tgz
NetBSD 9.0sparc64py36-trustme-0.6.0.tgz
NetBSD 9.0sparc64py37-trustme-0.6.0.tgz
NetBSD 9.0sparc64py38-trustme-0.6.0.tgz
NetBSD 9.0sparc64py39-trustme-0.6.0.tgz
NetBSD 9.0sparc64py27-trustme-0.6.0.tgz
NetBSD 9.0sparc64py36-trustme-0.6.0.tgz
NetBSD 9.0sparc64py37-trustme-0.6.0.tgz
NetBSD 9.0sparc64py38-trustme-0.6.0.tgz
NetBSD 9.0sparc64py27-trustme-0.6.0.tgz
NetBSD 9.0sparc64py36-trustme-0.6.0.tgz
NetBSD 9.0sparc64py37-trustme-0.6.0.tgz
NetBSD 9.0sparc64py38-trustme-0.6.0.tgz
NetBSD 9.0sparc64py39-trustme-0.6.0.tgz
NetBSD 9.0sparcpy27-trustme-0.6.0.tgz
NetBSD 9.0sparcpy36-trustme-0.6.0.tgz
NetBSD 9.0sparcpy37-trustme-0.6.0.tgz
NetBSD 9.0sparcpy38-trustme-0.6.0.tgz
NetBSD 9.0sparcpy39-trustme-0.6.0.tgz
NetBSD 9.0sparcpy27-trustme-0.6.0.tgz
NetBSD 9.0sparcpy36-trustme-0.6.0.tgz
NetBSD 9.0sparcpy37-trustme-0.6.0.tgz
NetBSD 9.0sparcpy38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py27-trustme-0.6.0.tgz
NetBSD 9.0x86_64py36-trustme-0.6.0.tgz
NetBSD 9.0x86_64py37-trustme-0.6.0.tgz
NetBSD 9.0x86_64py38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py39-trustme-0.6.0.tgz
NetBSD 9.0x86_64py27-trustme-0.6.0.tgz
NetBSD 9.0x86_64py36-trustme-0.6.0.tgz
NetBSD 9.0x86_64py37-trustme-0.6.0.tgz
NetBSD 9.0x86_64py38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py39-trustme-0.6.0.tgz
NetBSD 9.0x86_64py27-trustme-0.6.0.tgz
NetBSD 9.0x86_64py36-trustme-0.6.0.tgz
NetBSD 9.0x86_64py37-trustme-0.6.0.tgz
NetBSD 9.0x86_64py38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py39-trustme-0.6.0.tgz
NetBSD 9.0x86_64py27-trustme-0.6.0.tgz
NetBSD 9.0x86_64py36-trustme-0.6.0.tgz
NetBSD 9.0x86_64py37-trustme-0.6.0.tgz
NetBSD 9.0x86_64py38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py39-trustme-0.6.0.tgz
NetBSD 9.0x86_64py27-trustme-0.6.0.tgz
NetBSD 9.0x86_64py36-trustme-0.6.0.tgz
NetBSD 9.0x86_64py37-trustme-0.6.0.tgz
NetBSD 9.0x86_64py38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py27-trustme-0.6.0.tgz
NetBSD 9.0x86_64py36-trustme-0.6.0.tgz
NetBSD 9.0x86_64py37-trustme-0.6.0.tgz
NetBSD 9.0x86_64py38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py39-trustme-0.6.0.tgz
NetBSD 9.0x86_64py27-trustme-0.6.0.tgz
NetBSD 9.0x86_64py36-trustme-0.6.0.tgz
NetBSD 9.0x86_64py37-trustme-0.6.0.tgz
NetBSD 9.0x86_64py38-trustme-0.6.0.tgz
NetBSD 9.0x86_64py39-trustme-0.6.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.