security/pwsafe - The NetBSD Packages Collection

CLI based PasswordSafe compatible password manager

pwsafe is a unix commandline program that manages encrypted password
databases. There are few features listed:

* Pure command-line operation if desired (good for remote access over ssh).
* Can interact with X11 selection & clipboard.
* Portable, endianess-clean, misaligned-access-free C++.
* Compatible with CounterPane's PasswordSafe Win32 program versions 1.9.x.
* Funny comments included in source code.

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpwsafe-0.2.0nb10.tgz
NetBSD 8.0earmv7hfpwsafe-0.2.0nb10.tgz
NetBSD 8.0earmv7hfpwsafe-0.2.0nb10.tgz
NetBSD 8.0i386pwsafe-0.2.0nb10.tgz
NetBSD 8.0i386pwsafe-0.2.0nb10.tgz
NetBSD 8.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 8.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 8.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 8.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 8.0x86_64pwsafe-0.2.0nb10.tgz
NetBSD 8.0x86_64pwsafe-0.2.0nb10.tgz
NetBSD 9.0aarch64pwsafe-0.2.0nb10.tgz
NetBSD 9.0aarch64pwsafe-0.2.0nb10.tgz
NetBSD 9.0aarch64pwsafe-0.2.0nb10.tgz
NetBSD 9.0alphapwsafe-0.2.0nb10.tgz
NetBSD 9.0alphapwsafe-0.2.0nb10.tgz
NetBSD 9.0alphapwsafe-0.2.0nb10.tgz
NetBSD 9.0earmpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmv6hfpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmv6hfpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmv6hfpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmv7hfpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmv7hfpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmv7hfpwsafe-0.2.0nb10.tgz
NetBSD 9.0earmv7hfpwsafe-0.2.0nb10.tgz
NetBSD 9.0i386pwsafe-0.2.0nb10.tgz
NetBSD 9.0i386pwsafe-0.2.0nb10.tgz
NetBSD 9.0i386pwsafe-0.2.0nb10.tgz
NetBSD 9.0m68kpwsafe-0.2.0nb10.tgz
NetBSD 9.0m68kpwsafe-0.2.0nb10.tgz
NetBSD 9.0mips64ebpwsafe-0.2.0nb10.tgz
NetBSD 9.0mips64ebpwsafe-0.2.0nb10.tgz
NetBSD 9.0mips64ebpwsafe-0.2.0nb10.tgz
NetBSD 9.0mips64ebpwsafe-0.2.0nb10.tgz
NetBSD 9.0mips64ebpwsafe-0.2.0nb10.tgz
NetBSD 9.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 9.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 9.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 9.0powerpcpwsafe-0.2.0nb10.tgz
NetBSD 9.0sparc64pwsafe-0.2.0nb10.tgz
NetBSD 9.0sparc64pwsafe-0.2.0nb10.tgz
NetBSD 9.0sparc64pwsafe-0.2.0nb10.tgz
NetBSD 9.0sparcpwsafe-0.2.0nb10.tgz
NetBSD 9.0sparcpwsafe-0.2.0nb10.tgz
NetBSD 9.0sparcpwsafe-0.2.0nb10.tgz
NetBSD 9.0sparcpwsafe-0.2.0nb10.tgz
NetBSD 9.0x86_64pwsafe-0.2.0nb10.tgz
NetBSD 9.0x86_64pwsafe-0.2.0nb10.tgz
NetBSD 9.0x86_64pwsafe-0.2.0nb10.tgz
NetBSD 9.0x86_64pwsafe-0.2.0nb10.tgz
NetBSD 9.0x86_64pwsafe-0.2.0nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

readline
Enable use of GNU readline library.
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.