security/putty - The NetBSD Packages Collection

Free implementation of Telnet and SSH for Win32 and Unix platforms

PuTTY is a client program for the SSH, Telnet and Rlogin network protocols.

These protocols are all used to run a remote session on a computer, over a
network. PuTTY implements the client end of that session: the end at which
the session is displayed, rather than the end at which it runs.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/gmake devel/pkgconf

Runtime dependencies

x11/gtk3 x11/gtk3

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfputty-0.74nb2.tgz
NetBSD 8.0earmv7hfputty-0.74nb2.tgz
NetBSD 8.0i386putty-0.74nb1.tgz
NetBSD 8.0i386putty-0.74nb2.tgz
NetBSD 8.0i386putty-0.74nb2.tgz
NetBSD 8.0powerpcputty-0.74nb1.tgz
NetBSD 8.0powerpcputty-0.74nb2.tgz
NetBSD 8.0powerpcputty-0.74nb2.tgz
NetBSD 8.0x86_64putty-0.74nb2.tgz
NetBSD 8.0x86_64putty-0.74nb1.tgz
NetBSD 8.0x86_64putty-0.74nb2.tgz
NetBSD 9.0aarch64putty-0.74nb2.tgz
NetBSD 9.0aarch64putty-0.74nb1.tgz
NetBSD 9.0aarch64putty-0.74nb2.tgz
NetBSD 9.0alphaputty-0.74nb2.tgz
NetBSD 9.0alphaputty-0.74nb1.tgz
NetBSD 9.0alphaputty-0.74nb2.tgz
NetBSD 9.0earmv6hfputty-0.74nb2.tgz
NetBSD 9.0earmv6hfputty-0.74nb1.tgz
NetBSD 9.0earmv6hfputty-0.74nb2.tgz
NetBSD 9.0earmv6hfputty-0.74nb2.tgz
NetBSD 9.0earmv7hfputty-0.74nb2.tgz
NetBSD 9.0earmv7hfputty-0.74nb1.tgz
NetBSD 9.0earmv7hfputty-0.74nb2.tgz
NetBSD 9.0earmv7hfputty-0.74nb2.tgz
NetBSD 9.0earmv7hfputty-0.74nb2.tgz
NetBSD 9.0i386putty-0.74nb1.tgz
NetBSD 9.0i386putty-0.74nb2.tgz
NetBSD 9.0i386putty-0.74nb2.tgz
NetBSD 9.0mips64ebputty-0.74nb2.tgz
NetBSD 9.0mips64ebputty-0.74nb1.tgz
NetBSD 9.0mips64ebputty-0.74nb2.tgz
NetBSD 9.0powerpcputty-0.74nb2.tgz
NetBSD 9.0powerpcputty-0.74nb1.tgz
NetBSD 9.0powerpcputty-0.74nb2.tgz
NetBSD 9.0sparc64putty-0.74nb2.tgz
NetBSD 9.0sparc64putty-0.73nb2.tgz
NetBSD 9.0sparc64putty-0.74nb1.tgz
NetBSD 9.0sparc64putty-0.74nb2.tgz
NetBSD 9.0sparcputty-0.74nb1.tgz
NetBSD 9.0x86_64putty-0.74nb1.tgz
NetBSD 9.0x86_64putty-0.74nb2.tgz
NetBSD 9.0x86_64putty-0.74nb2.tgz
NetBSD 9.0x86_64putty-0.74nb2.tgz
NetBSD 9.0x86_64putty-0.74nb1.tgz
NetBSD 9.0x86_64putty-0.74nb2.tgz
NetBSD 9.0x86_64putty-0.74nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

inet6
Enable support for IPv6.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.