security/policykit-gnome - The NetBSD Packages Collection

GNOME dialogs for PolicyKit

PolicyKit is an application-level toolkit for defining and handling the
policy that allows unprivileged processes to speak to privileged processes:
It is a framework for centralizing the decision making process with respect
to granting access to privileged operations for unprivileged applications.
PolicyKit is specifically targeting applications in rich desktop environments
on multi-user UNIX-like operating systems. It does not imply or rely on any
exotic kernel features.

This package provides a D-Bus session bus service for bringing up
authentication dialogs used for obtaining privileges.

Build dependencies

pkgtools/x11-links textproc/gnome-doc-utils textproc/gnome-doc-utils x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/glib2-tools devel/libtool-base textproc/intltool devel/gmake lang/perl5 devel/pkgconf

Runtime dependencies

devel/GConf sysutils/dbus-glib security/policykit x11/gtk2 sysutils/desktop-file-utils devel/GConf sysutils/dbus-glib security/policykit x11/gtk2 sysutils/desktop-file-utils

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpolicykit-gnome-0.9.2nb46.tgz
NetBSD 8.0earmv7hfpolicykit-gnome-0.9.2nb45.tgz
NetBSD 8.0earmv7hfpolicykit-gnome-0.9.2nb46.tgz
NetBSD 8.0i386policykit-gnome-0.9.2nb45.tgz
NetBSD 8.0i386policykit-gnome-0.9.2nb46.tgz
NetBSD 8.0powerpcpolicykit-gnome-0.9.2nb45.tgz
NetBSD 8.0powerpcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 8.0powerpcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 8.0powerpcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 8.0x86_64policykit-gnome-0.9.2nb45.tgz
NetBSD 8.0x86_64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0aarch64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0aarch64policykit-gnome-0.9.2nb45.tgz
NetBSD 9.0aarch64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0alphapolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0alphapolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0alphapolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0earmpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0earmpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0earmpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0earmv6hfpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0earmv6hfpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0earmv6hfpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0earmv7hfpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0earmv7hfpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0earmv7hfpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0earmv7hfpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0i386policykit-gnome-0.9.2nb45.tgz
NetBSD 9.0i386policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0i386policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0mips64ebpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0mips64ebpolicykit-gnome-0.9.2nb44.tgz
NetBSD 9.0mips64ebpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0mips64ebpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0mips64ebpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0mipselpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0powerpcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0powerpcpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0powerpcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0powerpcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0sh3elpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0sh3elpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0sh3elpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0sh3elpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0sparc64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0sparc64policykit-gnome-0.9.2nb45.tgz
NetBSD 9.0sparc64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0sparcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0sparcpolicykit-gnome-0.9.2nb44.tgz
NetBSD 9.0sparcpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0sparcpolicykit-gnome-0.9.2nb45.tgz
NetBSD 9.0sparcpolicykit-gnome-0.9.2nb46.tgz
NetBSD 9.0x86_64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0x86_64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0x86_64policykit-gnome-0.9.2nb45.tgz
NetBSD 9.0x86_64policykit-gnome-0.9.2nb46.tgz
NetBSD 9.0x86_64policykit-gnome-0.9.2nb46.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.