security/php-gnupg - The NetBSD Packages Collection

PHP module for interacting with gnupg

PHP module for interacting with gnupg.
https://www.php.net/manual/en/book.gnupg

The extension supports only gnupg version 1 and the version 2 is not
currently supported.

Build dependencies

devel/pcre2 pkgtools/cwrappers devel/pcre2 devel/libtool-base devel/automake devel/autoconf devel/pkgconf

Runtime dependencies

security/gnupg2 security/gpgme lang/php74 security/gpgme lang/php74

Binary packages

OSArchitectureVersion
NetBSD 8.0powerpcphp56-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp73-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp74-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp80-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp56-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp73-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp74-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp80-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp56-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp73-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp74-gnupg-1.5.0.tgz
NetBSD 8.0powerpcphp80-gnupg-1.5.0.tgz
NetBSD 8.0x86_64php56-gnupg-1.5.0.tgz
NetBSD 8.0x86_64php73-gnupg-1.5.0.tgz
NetBSD 8.0x86_64php74-gnupg-1.5.0.tgz
NetBSD 8.0x86_64php80-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php56-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php73-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php74-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php80-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php56-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php73-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php74-gnupg-1.5.0.tgz
NetBSD 9.0aarch64php80-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp56-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp73-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp74-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp80-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp56-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp73-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp74-gnupg-1.5.0.tgz
NetBSD 9.0alphaphp80-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp56-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp73-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp74-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp80-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp56-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp73-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp74-gnupg-1.5.0.tgz
NetBSD 9.0mips64ebphp80-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp56-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp73-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp74-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp80-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp56-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp73-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp74-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp80-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp56-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp73-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp74-gnupg-1.5.0.tgz
NetBSD 9.0powerpcphp80-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php56-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php73-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php74-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php80-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php56-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php73-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php74-gnupg-1.5.0.tgz
NetBSD 9.0sparc64php80-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php56-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php73-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php74-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php80-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php56-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php73-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php74-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php80-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php56-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php73-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php74-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php80-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php56-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php73-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php74-gnupg-1.5.0.tgz
NetBSD 9.0x86_64php80-gnupg-1.5.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.