security/p5-Crypt-URandom - The NetBSD Packages Collection

Perl5 module to provide non blocking randomness

This Module is intended to provide an interface to the strongest available
source of non-blocking randomness on the current platform. Platforms
currently supported are anything supporting /dev/urandom and versions of
Windows greater than or equal to Windows 2000.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Crypt-URandom-0.36nb6.tgz
NetBSD 8.0earmv7hfp5-Crypt-URandom-0.36nb5.tgz
NetBSD 8.0earmv7hfp5-Crypt-URandom-0.36nb6.tgz
NetBSD 8.0i386p5-Crypt-URandom-0.36nb5.tgz
NetBSD 8.0i386p5-Crypt-URandom-0.36nb6.tgz
NetBSD 8.0powerpcp5-Crypt-URandom-0.36nb5.tgz
NetBSD 8.0powerpcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 8.0powerpcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 8.0powerpcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 8.0x86_64p5-Crypt-URandom-0.36nb5.tgz
NetBSD 8.0x86_64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0aarch64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0aarch64p5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0aarch64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0alphap5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0alphap5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0alphap5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0earmp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0earmp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0earmp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0earmv6hfp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0earmv6hfp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0earmv6hfp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0earmv7hfp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0earmv7hfp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0earmv7hfp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0earmv7hfp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0i386p5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0i386p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0mips64ebp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0mips64ebp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0mips64ebp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0mips64ebp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0mips64ebp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0mipselp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0mipselp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0mipselp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0mipselp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0powerpcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0powerpcp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0powerpcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0powerpcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0sh3elp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0sh3elp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0sh3elp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0sh3elp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0sparc64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0sparc64p5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0sparc64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0sparcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0sparcp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0sparcp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0sparcp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0sparcp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0vaxp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0vaxp5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0vaxp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0vaxp5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0x86_64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0x86_64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0x86_64p5-Crypt-URandom-0.36nb5.tgz
NetBSD 9.0x86_64p5-Crypt-URandom-0.36nb6.tgz
NetBSD 9.0x86_64p5-Crypt-URandom-0.36nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.