security/p5-Crypt-JWT - The NetBSD Packages Collection

Perl5 module for JSON Web Tokens

This perl module implements JSON Web Token (JWT). The implementation
covers not only JSON Web Signature (JWS), but also JSON Web Encryption
(JWE).

The module implements all algorithms defined in JSON Web Algorithms
(JWA).

This module supports Compact JWS/JWE and Flattened JWS/JWE JSON
serialization, general JSON serialization is not supported yet.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

converters/p5-JSON security/p5-CryptX lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Crypt-JWT-0.033.tgz
NetBSD 8.0earmv7hfp5-Crypt-JWT-0.029.tgz
NetBSD 8.0earmv7hfp5-Crypt-JWT-0.029nb1.tgz
NetBSD 8.0i386p5-Crypt-JWT-0.029.tgz
NetBSD 8.0i386p5-Crypt-JWT-0.029nb1.tgz
NetBSD 8.0powerpcp5-Crypt-JWT-0.029.tgz
NetBSD 8.0powerpcp5-Crypt-JWT-0.029nb1.tgz
NetBSD 8.0powerpcp5-Crypt-JWT-0.029nb1.tgz
NetBSD 8.0powerpcp5-Crypt-JWT-0.033.tgz
NetBSD 8.0x86_64p5-Crypt-JWT-0.029.tgz
NetBSD 8.0x86_64p5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0aarch64p5-Crypt-JWT-0.033.tgz
NetBSD 9.0aarch64p5-Crypt-JWT-0.029.tgz
NetBSD 9.0aarch64p5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0alphap5-Crypt-JWT-0.033.tgz
NetBSD 9.0alphap5-Crypt-JWT-0.029.tgz
NetBSD 9.0alphap5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0earmv6hfp5-Crypt-JWT-0.033.tgz
NetBSD 9.0earmv6hfp5-Crypt-JWT-0.029.tgz
NetBSD 9.0earmv6hfp5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0earmv7hfp5-Crypt-JWT-0.033.tgz
NetBSD 9.0earmv7hfp5-Crypt-JWT-0.029.tgz
NetBSD 9.0earmv7hfp5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0earmv7hfp5-Crypt-JWT-0.033.tgz
NetBSD 9.0i386p5-Crypt-JWT-0.029.tgz
NetBSD 9.0i386p5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0mips64ebp5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0mips64ebp5-Crypt-JWT-0.029.tgz
NetBSD 9.0mips64ebp5-Crypt-JWT-0.029.tgz
NetBSD 9.0mips64ebp5-Crypt-JWT-0.029.tgz
NetBSD 9.0mips64ebp5-Crypt-JWT-0.033.tgz
NetBSD 9.0powerpcp5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0powerpcp5-Crypt-JWT-0.029.tgz
NetBSD 9.0powerpcp5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0powerpcp5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0powerpcp5-Crypt-JWT-0.033.tgz
NetBSD 9.0sparc64p5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0sparc64p5-Crypt-JWT-0.029.tgz
NetBSD 9.0sparc64p5-Crypt-JWT-0.033.tgz
NetBSD 9.0sparcp5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0sparcp5-Crypt-JWT-0.029.tgz
NetBSD 9.0sparcp5-Crypt-JWT-0.033.tgz
NetBSD 9.0x86_64p5-Crypt-JWT-0.033.tgz
NetBSD 9.0x86_64p5-Crypt-JWT-0.033.tgz
NetBSD 9.0x86_64p5-Crypt-JWT-0.029.tgz
NetBSD 9.0x86_64p5-Crypt-JWT-0.029nb1.tgz
NetBSD 9.0x86_64p5-Crypt-JWT-0.033.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.