security/multigest - The NetBSD Packages Collection

Library and utility to calculate multiple message digests

The multigest utility calculates message digests of files or, if no
file is specified, standard input.  The list of possible algorithms is
given in the libmultigest(3) manual page.

The multigest utility is a simple wrapper for the various different
algorithm implementations, and was designed to be scalable as new
message digest algorithms are developed.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmultigest-20150211.tgz
NetBSD 8.0earmv7hfmultigest-20150211.tgz
NetBSD 8.0earmv7hfmultigest-20150211.tgz
NetBSD 8.0i386multigest-20150211.tgz
NetBSD 8.0i386multigest-20150211.tgz
NetBSD 8.0powerpcmultigest-20150211.tgz
NetBSD 8.0powerpcmultigest-20150211.tgz
NetBSD 8.0powerpcmultigest-20150211.tgz
NetBSD 8.0powerpcmultigest-20150211.tgz
NetBSD 8.0x86_64multigest-20150211.tgz
NetBSD 8.0x86_64multigest-20150211.tgz
NetBSD 9.0aarch64multigest-20150211.tgz
NetBSD 9.0aarch64multigest-20150211.tgz
NetBSD 9.0aarch64multigest-20150211.tgz
NetBSD 9.0alphamultigest-20150211.tgz
NetBSD 9.0alphamultigest-20150211.tgz
NetBSD 9.0alphamultigest-20150211.tgz
NetBSD 9.0earmmultigest-20150211.tgz
NetBSD 9.0earmmultigest-20150211.tgz
NetBSD 9.0earmv6hfmultigest-20150211.tgz
NetBSD 9.0earmv6hfmultigest-20150211.tgz
NetBSD 9.0earmv6hfmultigest-20150211.tgz
NetBSD 9.0earmv7hfmultigest-20150211.tgz
NetBSD 9.0earmv7hfmultigest-20150211.tgz
NetBSD 9.0earmv7hfmultigest-20150211.tgz
NetBSD 9.0earmv7hfmultigest-20150211.tgz
NetBSD 9.0i386multigest-20150211.tgz
NetBSD 9.0i386multigest-20150211.tgz
NetBSD 9.0i386multigest-20150211.tgz
NetBSD 9.0m68kmultigest-20150211.tgz
NetBSD 9.0mips64ebmultigest-20150211.tgz
NetBSD 9.0mips64ebmultigest-20150211.tgz
NetBSD 9.0mips64ebmultigest-20150211.tgz
NetBSD 9.0mips64ebmultigest-20150211.tgz
NetBSD 9.0mips64ebmultigest-20150211.tgz
NetBSD 9.0powerpcmultigest-20150211.tgz
NetBSD 9.0powerpcmultigest-20150211.tgz
NetBSD 9.0powerpcmultigest-20150211.tgz
NetBSD 9.0powerpcmultigest-20150211.tgz
NetBSD 9.0sparc64multigest-20150211.tgz
NetBSD 9.0sparc64multigest-20150211.tgz
NetBSD 9.0sparc64multigest-20150211.tgz
NetBSD 9.0sparcmultigest-20150211.tgz
NetBSD 9.0sparcmultigest-20150211.tgz
NetBSD 9.0sparcmultigest-20150211.tgz
NetBSD 9.0sparcmultigest-20150211.tgz
NetBSD 9.0x86_64multigest-20150211.tgz
NetBSD 9.0x86_64multigest-20150211.tgz
NetBSD 9.0x86_64multigest-20150211.tgz
NetBSD 9.0x86_64multigest-20150211.tgz
NetBSD 9.0x86_64multigest-20150211.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.