security/mcrypt - The NetBSD Packages Collection

Replacement to crypt(1), supports many crypto algorithms

Mcrypt:

mcrypt is intended to be a replacement of the old unix crypt(1)
under the GNU General Public License. Unix Crypt(1) was a popular(?)
file encryption program in unix boxes. It was based on the enigma
encryption algorithm but it was considerable trivialized. Since
this was not adequate, even for individual privacy needs, I decided
to create a similar program using some modern block encryption
algorithms. Mcrypt also has a compatibility mode with unix crypt(1)
and with solaris des(1). It supports all the algorithms and modes
found in libmcrypt and it is very extendable. At the time writing
this, it supports the algorithms: BLOWFISH, TWOFISH, DES, TripleDES,
3-WAY, SAFER, LOKI97, GOST, RC2, RC6, MARS, IDEA, RIJNDAEL, SERPENT,
CAST, ARCFOUR and WAKE.  Block algorithms are implemented in modes:
CFB, CBC, ECB, OFB (8 bit and n bit, where n is the size of the
algorithm's block length). For a brief description of the algorithms
and the modes look at the mcrypt manpage (this may be out of date).
In mcrypt it is on the user to decide which algorithm he considers
best for encrypting his data.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

security/libmcrypt security/mhash security/libmcrypt

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmcrypt-2.6.8nb4.tgz
NetBSD 8.0earmv7hfmcrypt-2.6.8nb4.tgz
NetBSD 8.0earmv7hfmcrypt-2.6.8nb4.tgz
NetBSD 8.0i386mcrypt-2.6.8nb4.tgz
NetBSD 8.0i386mcrypt-2.6.8nb4.tgz
NetBSD 8.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 8.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 8.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 8.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 8.0x86_64mcrypt-2.6.8nb4.tgz
NetBSD 8.0x86_64mcrypt-2.6.8nb4.tgz
NetBSD 9.0aarch64mcrypt-2.6.8nb4.tgz
NetBSD 9.0aarch64mcrypt-2.6.8nb4.tgz
NetBSD 9.0aarch64mcrypt-2.6.8nb4.tgz
NetBSD 9.0alphamcrypt-2.6.8nb4.tgz
NetBSD 9.0alphamcrypt-2.6.8nb4.tgz
NetBSD 9.0alphamcrypt-2.6.8nb4.tgz
NetBSD 9.0earmv6hfmcrypt-2.6.8nb4.tgz
NetBSD 9.0earmv6hfmcrypt-2.6.8nb4.tgz
NetBSD 9.0earmv6hfmcrypt-2.6.8nb4.tgz
NetBSD 9.0earmv7hfmcrypt-2.6.8nb4.tgz
NetBSD 9.0earmv7hfmcrypt-2.6.8nb4.tgz
NetBSD 9.0earmv7hfmcrypt-2.6.8nb4.tgz
NetBSD 9.0earmv7hfmcrypt-2.6.8nb4.tgz
NetBSD 9.0i386mcrypt-2.6.8nb4.tgz
NetBSD 9.0i386mcrypt-2.6.8nb4.tgz
NetBSD 9.0mips64ebmcrypt-2.6.8nb4.tgz
NetBSD 9.0mips64ebmcrypt-2.6.8nb4.tgz
NetBSD 9.0mips64ebmcrypt-2.6.8nb4.tgz
NetBSD 9.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 9.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 9.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 9.0powerpcmcrypt-2.6.8nb4.tgz
NetBSD 9.0sparc64mcrypt-2.6.8nb4.tgz
NetBSD 9.0sparc64mcrypt-2.6.8nb4.tgz
NetBSD 9.0sparc64mcrypt-2.6.8nb4.tgz
NetBSD 9.0sparcmcrypt-2.6.8nb4.tgz
NetBSD 9.0sparcmcrypt-2.6.8nb4.tgz
NetBSD 9.0sparcmcrypt-2.6.8nb4.tgz
NetBSD 9.0x86_64mcrypt-2.6.8nb4.tgz
NetBSD 9.0x86_64mcrypt-2.6.8nb4.tgz
NetBSD 9.0x86_64mcrypt-2.6.8nb4.tgz
NetBSD 9.0x86_64mcrypt-2.6.8nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.