security/libressl - The NetBSD Packages Collection

Secure Sockets Layer and cryptography libraries and tools

This package is the official portable version of LibreSSL

LibreSSL is a fork of OpenSSL developed by the OpenBSD project
(http://www.openbsd.org). LibreSSL is developed on OpenBSD. This
package then adds portability shims for other operating systems.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibressl-2.7.4nb1.tgz
NetBSD 8.0earmv7hflibressl-2.7.4nb1.tgz
NetBSD 8.0earmv7hflibressl-2.7.4nb1.tgz
NetBSD 8.0i386libressl-2.7.4nb1.tgz
NetBSD 8.0i386libressl-2.7.4nb1.tgz
NetBSD 8.0powerpclibressl-2.7.4nb1.tgz
NetBSD 8.0powerpclibressl-2.7.4nb1.tgz
NetBSD 8.0powerpclibressl-2.7.4nb1.tgz
NetBSD 8.0powerpclibressl-2.7.4nb1.tgz
NetBSD 8.0x86_64libressl-2.7.4nb1.tgz
NetBSD 8.0x86_64libressl-2.7.4nb1.tgz
NetBSD 9.0aarch64libressl-2.7.4nb1.tgz
NetBSD 9.0aarch64libressl-2.7.4nb1.tgz
NetBSD 9.0aarch64libressl-2.7.4nb1.tgz
NetBSD 9.0alphalibressl-2.7.4nb1.tgz
NetBSD 9.0alphalibressl-2.7.4nb1.tgz
NetBSD 9.0alphalibressl-2.7.4nb1.tgz
NetBSD 9.0earmv6hflibressl-2.7.4nb1.tgz
NetBSD 9.0earmv6hflibressl-2.7.4nb1.tgz
NetBSD 9.0earmv6hflibressl-2.7.4nb1.tgz
NetBSD 9.0earmv7hflibressl-2.7.4nb1.tgz
NetBSD 9.0earmv7hflibressl-2.7.4nb1.tgz
NetBSD 9.0earmv7hflibressl-2.7.4nb1.tgz
NetBSD 9.0earmv7hflibressl-2.7.4nb1.tgz
NetBSD 9.0i386libressl-2.7.4nb1.tgz
NetBSD 9.0i386libressl-2.7.4nb1.tgz
NetBSD 9.0mips64eblibressl-2.7.4nb1.tgz
NetBSD 9.0mips64eblibressl-2.7.4.tgz
NetBSD 9.0mips64eblibressl-2.7.4nb1.tgz
NetBSD 9.0mips64eblibressl-2.7.4nb1.tgz
NetBSD 9.0mips64eblibressl-2.7.4nb1.tgz
NetBSD 9.0powerpclibressl-2.7.4nb1.tgz
NetBSD 9.0powerpclibressl-2.7.4nb1.tgz
NetBSD 9.0powerpclibressl-2.7.4nb1.tgz
NetBSD 9.0powerpclibressl-2.7.4nb1.tgz
NetBSD 9.0sparc64libressl-2.7.4nb1.tgz
NetBSD 9.0sparc64libressl-2.7.4nb1.tgz
NetBSD 9.0sparc64libressl-2.7.4nb1.tgz
NetBSD 9.0sparclibressl-2.7.4nb1.tgz
NetBSD 9.0sparclibressl-2.7.4.tgz
NetBSD 9.0sparclibressl-2.7.4nb1.tgz
NetBSD 9.0sparclibressl-2.7.4nb1.tgz
NetBSD 9.0x86_64libressl-2.7.4nb1.tgz
NetBSD 9.0x86_64libressl-2.7.4nb1.tgz
NetBSD 9.0x86_64libressl-2.7.4nb1.tgz
NetBSD 9.0x86_64libressl-2.7.4nb1.tgz
NetBSD 9.0x86_64libressl-2.7.4nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.