security/libgcrypt - The NetBSD Packages Collection

GNU cryptographic library

This is a general purpose cryptographic library based on the code from GnuPG.
It provides functions for all cryptograhic building blocks: symmetric ciphers
(AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash algorithms (MD4, MD5,
RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all hash algorithms), public key
algorithms (RSA, ElGamal, DSA), large integer functions, random numbers and a
lot of supporting functions.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

security/libgpg-error security/libgpg-error security/libgpg-error

Available binary packages

aarch64:libgcrypt-1.8.5.tgz(NetBSD 9.0)
aarch64:libgcrypt-1.8.6.tgz(NetBSD 9.0)
aarch64:libgcrypt-1.8.7.tgz(NetBSD 9.0)
alpha:libgcrypt-1.8.7.tgz(NetBSD 9.0)
alpha:libgcrypt-1.8.5.tgz(NetBSD 9.0)
alpha:libgcrypt-1.8.6.tgz(NetBSD 9.0)
earm:libgcrypt-1.8.6.tgz(NetBSD 9.0)
earm:libgcrypt-1.8.5.tgz(NetBSD 9.0)
earm:libgcrypt-1.8.7.tgz(NetBSD 9.0)
earmv6hf:libgcrypt-1.8.7.tgz(NetBSD 9.0)
earmv6hf:libgcrypt-1.8.5.tgz(NetBSD 9.0)
earmv6hf:libgcrypt-1.8.6.tgz(NetBSD 9.0)
earmv6hf:libgcrypt-1.8.7.tgz(NetBSD 9.0)
earmv7hf:libgcrypt-1.8.7.tgz(NetBSD 8.0)
earmv7hf:libgcrypt-1.8.5.tgz(NetBSD 8.0)
earmv7hf:libgcrypt-1.8.5.tgz(NetBSD 8.0)
earmv7hf:libgcrypt-1.8.6.tgz(NetBSD 8.0)
earmv7hf:libgcrypt-1.8.7.tgz(NetBSD 8.0)
earmv7hf:libgcrypt-1.8.7.tgz(NetBSD 9.0)
earmv7hf:libgcrypt-1.8.5.tgz(NetBSD 9.0)
earmv7hf:libgcrypt-1.8.5.tgz(NetBSD 9.0)
earmv7hf:libgcrypt-1.8.6.tgz(NetBSD 9.0)
earmv7hf:libgcrypt-1.8.7.tgz(NetBSD 9.0)
earmv7hf:libgcrypt-1.8.7.tgz(NetBSD 9.0)
i386:libgcrypt-1.8.5.tgz(NetBSD 8.0)
i386:libgcrypt-1.8.6.tgz(NetBSD 8.0)
i386:libgcrypt-1.8.7.tgz(NetBSD 8.0)
i386:libgcrypt-1.8.5.tgz(NetBSD 9.0)
i386:libgcrypt-1.8.6.tgz(NetBSD 9.0)
i386:libgcrypt-1.8.7.tgz(NetBSD 9.0)
m68k:libgcrypt-1.8.6.tgz(NetBSD 9.0)
m68k:libgcrypt-1.8.5.tgz(NetBSD 9.0)
m68k:libgcrypt-1.8.5.tgz(NetBSD 9.0)
m68k:libgcrypt-1.8.7.tgz(NetBSD 9.0)
mips64eb:libgcrypt-1.8.6.tgz(NetBSD 9.0)
mips64eb:libgcrypt-1.8.7.tgz(NetBSD 9.0)
mipsel:libgcrypt-1.8.7.tgz(NetBSD 9.0)
powerpc:libgcrypt-1.8.5.tgz(NetBSD 8.0)
powerpc:libgcrypt-1.8.6.tgz(NetBSD 8.0)
powerpc:libgcrypt-1.8.7.tgz(NetBSD 8.0)
powerpc:libgcrypt-1.8.7.tgz(NetBSD 9.0)
powerpc:libgcrypt-1.8.5.tgz(NetBSD 9.0)
powerpc:libgcrypt-1.8.6.tgz(NetBSD 9.0)
sh3el:libgcrypt-1.8.6.tgz(NetBSD 9.0)
sh3el:libgcrypt-1.8.7.tgz(NetBSD 9.0)
sparc64:libgcrypt-1.8.7.tgz(NetBSD 9.0)
sparc64:libgcrypt-1.8.5.tgz(NetBSD 9.0)
sparc64:libgcrypt-1.8.6.tgz(NetBSD 9.0)
sparc:libgcrypt-1.8.6.tgz(NetBSD 9.0)
sparc:libgcrypt-1.8.5.tgz(NetBSD 9.0)
sparc:libgcrypt-1.8.7.tgz(NetBSD 9.0)
vax:libgcrypt-1.8.7.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.8.7.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.8.7.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.9.1.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.8.6.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.8.6.tgz(NetBSD 8.0)
x86_64:libgcrypt-1.8.5.tgz(NetBSD 8.0)
x86_64:libgcrypt-1.8.7.tgz(NetBSD 8.0)
x86_64:libgcrypt-1.8.5.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.8.6.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.8.7.tgz(NetBSD 9.0)
x86_64:libgcrypt-1.9.1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)
(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]