security/libfido2 - The NetBSD Packages Collection

U2F/FIDO/FIDO2 library and tools

libfido2 provides library functionality and command-line tools to
communicate with a FIDO device over USB, and to verify attestation and
assertion signatures.

libfido2 supports the FIDO U2F (CTAP 1) and FIDO 2.0 (CTAP 2)
protocols.

Build dependencies

pkgtools/cwrappers devel/cmake

Runtime dependencies

devel/libcbor

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibfido2-1.5.0nb1.tgz
NetBSD 8.0earmv7hflibfido2-1.5.0nb1.tgz
NetBSD 8.0earmv7hflibfido2-1.5.0nb1.tgz
NetBSD 8.0i386libfido2-1.5.0nb1.tgz
NetBSD 8.0i386libfido2-1.5.0nb1.tgz
NetBSD 8.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 8.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 8.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 8.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 8.0x86_64libfido2-1.5.0nb1.tgz
NetBSD 8.0x86_64libfido2-1.5.0nb1.tgz
NetBSD 9.0aarch64libfido2-1.5.0nb1.tgz
NetBSD 9.0aarch64libfido2-1.5.0nb1.tgz
NetBSD 9.0aarch64libfido2-1.5.0nb1.tgz
NetBSD 9.0alphalibfido2-1.5.0nb1.tgz
NetBSD 9.0alphalibfido2-1.5.0nb1.tgz
NetBSD 9.0alphalibfido2-1.5.0nb1.tgz
NetBSD 9.0earmlibfido2-1.5.0nb1.tgz
NetBSD 9.0earmlibfido2-1.5.0nb1.tgz
NetBSD 9.0earmlibfido2-1.5.0nb1.tgz
NetBSD 9.0earmv6hflibfido2-1.5.0nb1.tgz
NetBSD 9.0earmv6hflibfido2-1.5.0nb1.tgz
NetBSD 9.0earmv6hflibfido2-1.5.0nb1.tgz
NetBSD 9.0earmv7hflibfido2-1.5.0nb1.tgz
NetBSD 9.0earmv7hflibfido2-1.5.0nb1.tgz
NetBSD 9.0earmv7hflibfido2-1.5.0nb1.tgz
NetBSD 9.0earmv7hflibfido2-1.5.0nb1.tgz
NetBSD 9.0i386libfido2-1.5.0nb1.tgz
NetBSD 9.0i386libfido2-1.5.0nb1.tgz
NetBSD 9.0i386libfido2-1.5.0nb1.tgz
NetBSD 9.0mips64eblibfido2-1.5.0nb1.tgz
NetBSD 9.0mips64eblibfido2-1.4.0.tgz
NetBSD 9.0mips64eblibfido2-1.5.0nb1.tgz
NetBSD 9.0mips64eblibfido2-1.5.0nb1.tgz
NetBSD 9.0mips64eblibfido2-1.5.0nb1.tgz
NetBSD 9.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 9.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 9.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 9.0powerpclibfido2-1.5.0nb1.tgz
NetBSD 9.0sparc64libfido2-1.5.0nb1.tgz
NetBSD 9.0sparc64libfido2-1.5.0nb1.tgz
NetBSD 9.0sparc64libfido2-1.5.0nb1.tgz
NetBSD 9.0sparclibfido2-1.5.0nb1.tgz
NetBSD 9.0sparclibfido2-1.5.0nb1.tgz
NetBSD 9.0sparclibfido2-1.5.0nb1.tgz
NetBSD 9.0sparclibfido2-1.5.0nb1.tgz
NetBSD 9.0x86_64libfido2-1.5.0nb1.tgz
NetBSD 9.0x86_64libfido2-1.5.0nb1.tgz
NetBSD 9.0x86_64libfido2-1.5.0nb1.tgz
NetBSD 9.0x86_64libfido2-1.5.0nb1.tgz
NetBSD 9.0x86_64libfido2-1.5.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.