security/lasso - The NetBSD Packages Collection

Liberty Alliance Single Sign On implementation

Lasso is a free software C library aiming to implement the Liberty
Alliance standards: ID-FF, ID-WSF and SAML. It defines processes for
federated identities, single sign-on and related protocols. Lasso is
built on top of libxml2, XMLSec and OpenSSL and is GPL licensed.

Build dependencies

lang/python27 pkgtools/cwrappers lang/python27 devel/glib2-tools devel/libtool-base lang/perl5 devel/pkgconf

Runtime dependencies

lang/py-six security/xmlsec1 textproc/libxml2 textproc/libxslt security/cyrus-sasl devel/glib2 security/xmlsec1 textproc/libxml2 textproc/libxslt security/cyrus-sasl devel/glib2 devel/glib2

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflasso-2.7.0.tgz
NetBSD 8.0earmv7hflasso-2.6.1nb3.tgz
NetBSD 8.0earmv7hflasso-2.7.0.tgz
NetBSD 8.0i386lasso-2.6.1nb3.tgz
NetBSD 8.0i386lasso-2.7.0.tgz
NetBSD 8.0powerpclasso-2.6.1nb3.tgz
NetBSD 8.0powerpclasso-2.7.0.tgz
NetBSD 8.0powerpclasso-2.7.0.tgz
NetBSD 8.0powerpclasso-2.7.0.tgz
NetBSD 8.0x86_64lasso-2.6.1nb3.tgz
NetBSD 8.0x86_64lasso-2.7.0.tgz
NetBSD 9.0aarch64lasso-2.7.0.tgz
NetBSD 9.0aarch64lasso-2.6.1nb3.tgz
NetBSD 9.0aarch64lasso-2.7.0.tgz
NetBSD 9.0alphalasso-2.7.0.tgz
NetBSD 9.0alphalasso-2.6.1nb3.tgz
NetBSD 9.0alphalasso-2.7.0.tgz
NetBSD 9.0earmlasso-2.6.1nb3.tgz
NetBSD 9.0earmlasso-2.7.0.tgz
NetBSD 9.0earmlasso-2.7.0.tgz
NetBSD 9.0earmv6hflasso-2.7.0.tgz
NetBSD 9.0earmv6hflasso-2.6.1nb3.tgz
NetBSD 9.0earmv6hflasso-2.7.0.tgz
NetBSD 9.0earmv7hflasso-2.7.0.tgz
NetBSD 9.0earmv7hflasso-2.6.1nb3.tgz
NetBSD 9.0earmv7hflasso-2.7.0.tgz
NetBSD 9.0earmv7hflasso-2.7.0.tgz
NetBSD 9.0i386lasso-2.6.1nb3.tgz
NetBSD 9.0i386lasso-2.7.0.tgz
NetBSD 9.0i386lasso-2.7.0.tgz
NetBSD 9.0mips64eblasso-2.7.0.tgz
NetBSD 9.0mips64eblasso-2.6.1nb1.tgz
NetBSD 9.0mips64eblasso-2.6.1nb3.tgz
NetBSD 9.0mips64eblasso-2.6.1nb3.tgz
NetBSD 9.0mips64eblasso-2.7.0.tgz
NetBSD 9.0mipsellasso-2.7.0.tgz
NetBSD 9.0mipsellasso-2.6.1nb3.tgz
NetBSD 9.0mipsellasso-2.6.1nb3.tgz
NetBSD 9.0mipsellasso-2.7.0.tgz
NetBSD 9.0powerpclasso-2.7.0.tgz
NetBSD 9.0powerpclasso-2.6.1nb3.tgz
NetBSD 9.0powerpclasso-2.7.0.tgz
NetBSD 9.0powerpclasso-2.7.0.tgz
NetBSD 9.0sh3ellasso-2.7.0.tgz
NetBSD 9.0sh3ellasso-2.6.1nb3.tgz
NetBSD 9.0sh3ellasso-2.6.1nb3.tgz
NetBSD 9.0sh3ellasso-2.7.0.tgz
NetBSD 9.0sparc64lasso-2.7.0.tgz
NetBSD 9.0sparc64lasso-2.6.1nb3.tgz
NetBSD 9.0sparc64lasso-2.7.0.tgz
NetBSD 9.0sparclasso-2.7.0.tgz
NetBSD 9.0sparclasso-2.6.1nb1.tgz
NetBSD 9.0sparclasso-2.6.1nb3.tgz
NetBSD 9.0sparclasso-2.6.1nb3.tgz
NetBSD 9.0sparclasso-2.7.0.tgz
NetBSD 9.0x86_64lasso-2.7.0.tgz
NetBSD 9.0x86_64lasso-2.7.0.tgz
NetBSD 9.0x86_64lasso-2.6.1nb3.tgz
NetBSD 9.0x86_64lasso-2.7.0.tgz
NetBSD 9.0x86_64lasso-2.7.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.