security/hackbot - The NetBSD Packages Collection

Vulnerability scanner written in Perl

Hackbot is a vulnerability scanner that started as a joke at first, but now
it has become a serious project. Hackbot scans over 300 CGI's, scans for
banners of several services, does unicode checks, checks for open relays,
outsmarts Cisco PIX MailGuard, can do ripe checkup, spamcop db checkup, X
connect test and lots more.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfhackbot-2.21nb8.tgz
NetBSD 8.0earmv7hfhackbot-2.21nb7.tgz
NetBSD 8.0earmv7hfhackbot-2.21nb8.tgz
NetBSD 8.0i386hackbot-2.21nb7.tgz
NetBSD 8.0i386hackbot-2.21nb8.tgz
NetBSD 8.0powerpchackbot-2.21nb7.tgz
NetBSD 8.0powerpchackbot-2.21nb8.tgz
NetBSD 8.0powerpchackbot-2.21nb8.tgz
NetBSD 8.0powerpchackbot-2.21nb8.tgz
NetBSD 8.0x86_64hackbot-2.21nb7.tgz
NetBSD 8.0x86_64hackbot-2.21nb8.tgz
NetBSD 9.0aarch64hackbot-2.21nb8.tgz
NetBSD 9.0aarch64hackbot-2.21nb7.tgz
NetBSD 9.0aarch64hackbot-2.21nb8.tgz
NetBSD 9.0alphahackbot-2.21nb8.tgz
NetBSD 9.0alphahackbot-2.21nb7.tgz
NetBSD 9.0alphahackbot-2.21nb8.tgz
NetBSD 9.0earmhackbot-2.21nb7.tgz
NetBSD 9.0earmhackbot-2.21nb8.tgz
NetBSD 9.0earmhackbot-2.21nb8.tgz
NetBSD 9.0earmv6hfhackbot-2.21nb8.tgz
NetBSD 9.0earmv6hfhackbot-2.21nb7.tgz
NetBSD 9.0earmv6hfhackbot-2.21nb8.tgz
NetBSD 9.0earmv7hfhackbot-2.21nb8.tgz
NetBSD 9.0earmv7hfhackbot-2.21nb7.tgz
NetBSD 9.0earmv7hfhackbot-2.21nb8.tgz
NetBSD 9.0earmv7hfhackbot-2.21nb8.tgz
NetBSD 9.0i386hackbot-2.21nb7.tgz
NetBSD 9.0i386hackbot-2.21nb8.tgz
NetBSD 9.0mips64ebhackbot-2.21nb8.tgz
NetBSD 9.0mips64ebhackbot-2.21nb7.tgz
NetBSD 9.0mips64ebhackbot-2.21nb7.tgz
NetBSD 9.0mips64ebhackbot-2.21nb7.tgz
NetBSD 9.0mips64ebhackbot-2.21nb8.tgz
NetBSD 9.0powerpchackbot-2.21nb8.tgz
NetBSD 9.0powerpchackbot-2.21nb7.tgz
NetBSD 9.0powerpchackbot-2.21nb8.tgz
NetBSD 9.0powerpchackbot-2.21nb8.tgz
NetBSD 9.0sparc64hackbot-2.21nb8.tgz
NetBSD 9.0sparc64hackbot-2.21nb7.tgz
NetBSD 9.0sparc64hackbot-2.21nb8.tgz
NetBSD 9.0sparchackbot-2.21nb8.tgz
NetBSD 9.0sparchackbot-2.21nb7.tgz
NetBSD 9.0sparchackbot-2.21nb7.tgz
NetBSD 9.0sparchackbot-2.21nb8.tgz
NetBSD 9.0x86_64hackbot-2.21nb8.tgz
NetBSD 9.0x86_64hackbot-2.21nb8.tgz
NetBSD 9.0x86_64hackbot-2.21nb7.tgz
NetBSD 9.0x86_64hackbot-2.21nb8.tgz
NetBSD 9.0x86_64hackbot-2.21nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.