security/fail2ban - The NetBSD Packages Collection

Scans log files and bans IP that makes too many password failures

Fail2Ban scans log files like /var/log/pwdfail and bans IP
that makes too many password failures. It updates firewall
rules to reject the IP address. Theses rules can be defined by
the user. Fail2Ban can read multiple log files such as sshd
or Apache web server ones.

Build dependencies

textproc/py-numpydoc textproc/py-sphinx pkgtools/cwrappers

Runtime dependencies

databases/py-sqlite3 lang/python39 lang/python39

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffail2ban-0.11.1nb1.tgz
NetBSD 8.0earmv7hffail2ban-0.11.1nb1.tgz
NetBSD 8.0earmv7hffail2ban-0.11.1nb1.tgz
NetBSD 8.0i386fail2ban-0.11.1nb1.tgz
NetBSD 8.0i386fail2ban-0.11.1nb1.tgz
NetBSD 8.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 8.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 8.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 8.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 8.0x86_64fail2ban-0.11.1nb1.tgz
NetBSD 8.0x86_64fail2ban-0.11.1nb1.tgz
NetBSD 9.0aarch64fail2ban-0.11.1nb1.tgz
NetBSD 9.0aarch64fail2ban-0.11.1nb1.tgz
NetBSD 9.0aarch64fail2ban-0.11.1nb1.tgz
NetBSD 9.0alphafail2ban-0.11.1nb1.tgz
NetBSD 9.0alphafail2ban-0.11.1nb1.tgz
NetBSD 9.0alphafail2ban-0.11.1nb1.tgz
NetBSD 9.0earmv6hffail2ban-0.11.1nb1.tgz
NetBSD 9.0earmv6hffail2ban-0.11.1nb1.tgz
NetBSD 9.0earmv6hffail2ban-0.11.1nb1.tgz
NetBSD 9.0earmv7hffail2ban-0.11.1nb1.tgz
NetBSD 9.0earmv7hffail2ban-0.11.1nb1.tgz
NetBSD 9.0earmv7hffail2ban-0.11.1nb1.tgz
NetBSD 9.0earmv7hffail2ban-0.11.1nb1.tgz
NetBSD 9.0i386fail2ban-0.11.1nb1.tgz
NetBSD 9.0i386fail2ban-0.11.1nb1.tgz
NetBSD 9.0mips64ebfail2ban-0.11.1nb1.tgz
NetBSD 9.0mips64ebfail2ban-0.11.1.tgz
NetBSD 9.0mips64ebfail2ban-0.11.1nb1.tgz
NetBSD 9.0mips64ebfail2ban-0.11.1nb1.tgz
NetBSD 9.0mips64ebfail2ban-0.11.1nb1.tgz
NetBSD 9.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 9.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 9.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 9.0powerpcfail2ban-0.11.1nb1.tgz
NetBSD 9.0sparc64fail2ban-0.11.1nb1.tgz
NetBSD 9.0sparc64fail2ban-0.11.1nb1.tgz
NetBSD 9.0sparc64fail2ban-0.11.1nb1.tgz
NetBSD 9.0sparcfail2ban-0.11.1nb1.tgz
NetBSD 9.0sparcfail2ban-0.11.1nb1.tgz
NetBSD 9.0sparcfail2ban-0.11.1nb1.tgz
NetBSD 9.0x86_64fail2ban-0.11.1nb1.tgz
NetBSD 9.0x86_64fail2ban-0.11.1nb1.tgz
NetBSD 9.0x86_64fail2ban-0.11.1nb1.tgz
NetBSD 9.0x86_64fail2ban-0.11.1nb1.tgz
NetBSD 9.0x86_64fail2ban-0.11.1nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gamin
Enable Gamin file and directory monitoring system support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.