security/dcfldd - The NetBSD Packages Collection

Enhanced version of GNU dd with features useful for forensics

dcfldd is an enhanced version of GNU dd with features useful for
forensics and security. Based on the dd program found in the GNU
Coreutils package, dcfldd has the following additional features:

* Hashing on-the-fly - dcfldd can hash the input data as it is being
  transferred, helping to ensure data integrity.
* Status output - dcfldd can update the user of its progress in terms
  of the amount of data transferred and how much longer operation will take.
* Flexible disk wipes - dcfldd can be used to wipe disks quickly and
  with a known pattern if desired.
* Image/wipe Verify - dcfldd can verify that a target drive is a
  bit-for-bit match of the specified input file or pattern.
* Multiple outputs - dcfldd can output to multiple files or disks at
  the same time.
* Split output - dcfldd can split output to multiple files with more
  configurability than the split command.
* Piped output and logs - dcfldd can send all its log data and output
  to commands as well as files natively.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfdcfldd-1.3.4.tgz
NetBSD 8.0earmv7hfdcfldd-1.3.4.tgz
NetBSD 8.0earmv7hfdcfldd-1.3.4.tgz
NetBSD 8.0i386dcfldd-1.3.4.tgz
NetBSD 8.0i386dcfldd-1.3.4.tgz
NetBSD 8.0powerpcdcfldd-1.3.4.tgz
NetBSD 8.0powerpcdcfldd-1.3.4.tgz
NetBSD 8.0powerpcdcfldd-1.3.4.tgz
NetBSD 8.0powerpcdcfldd-1.3.4.tgz
NetBSD 8.0x86_64dcfldd-1.3.4.tgz
NetBSD 8.0x86_64dcfldd-1.3.4.tgz
NetBSD 9.0aarch64dcfldd-1.3.4.tgz
NetBSD 9.0aarch64dcfldd-1.3.4.tgz
NetBSD 9.0aarch64dcfldd-1.3.4.tgz
NetBSD 9.0alphadcfldd-1.3.4.tgz
NetBSD 9.0alphadcfldd-1.3.4.tgz
NetBSD 9.0alphadcfldd-1.3.4.tgz
NetBSD 9.0earmdcfldd-1.3.4.tgz
NetBSD 9.0earmdcfldd-1.3.4.tgz
NetBSD 9.0earmdcfldd-1.3.4.tgz
NetBSD 9.0earmv6hfdcfldd-1.3.4.tgz
NetBSD 9.0earmv6hfdcfldd-1.3.4.tgz
NetBSD 9.0earmv6hfdcfldd-1.3.4.tgz
NetBSD 9.0earmv7hfdcfldd-1.3.4.tgz
NetBSD 9.0earmv7hfdcfldd-1.3.4.tgz
NetBSD 9.0earmv7hfdcfldd-1.3.4.tgz
NetBSD 9.0earmv7hfdcfldd-1.3.4.tgz
NetBSD 9.0i386dcfldd-1.3.4.tgz
NetBSD 9.0i386dcfldd-1.3.4.tgz
NetBSD 9.0m68kdcfldd-1.3.4.tgz
NetBSD 9.0m68kdcfldd-1.3.4.tgz
NetBSD 9.0mips64ebdcfldd-1.3.4.tgz
NetBSD 9.0mips64ebdcfldd-1.3.4.tgz
NetBSD 9.0mips64ebdcfldd-1.3.4.tgz
NetBSD 9.0mips64ebdcfldd-1.3.4.tgz
NetBSD 9.0mips64ebdcfldd-1.3.4.tgz
NetBSD 9.0powerpcdcfldd-1.3.4.tgz
NetBSD 9.0powerpcdcfldd-1.3.4.tgz
NetBSD 9.0powerpcdcfldd-1.3.4.tgz
NetBSD 9.0powerpcdcfldd-1.3.4.tgz
NetBSD 9.0sparc64dcfldd-1.3.4.tgz
NetBSD 9.0sparc64dcfldd-1.3.4.tgz
NetBSD 9.0sparc64dcfldd-1.3.4.tgz
NetBSD 9.0sparcdcfldd-1.3.4.tgz
NetBSD 9.0sparcdcfldd-1.3.4.tgz
NetBSD 9.0sparcdcfldd-1.3.4.tgz
NetBSD 9.0sparcdcfldd-1.3.4.tgz
NetBSD 9.0x86_64dcfldd-1.3.4.tgz
NetBSD 9.0x86_64dcfldd-1.3.4.tgz
NetBSD 9.0x86_64dcfldd-1.3.4.tgz
NetBSD 9.0x86_64dcfldd-1.3.4.tgz
NetBSD 9.0x86_64dcfldd-1.3.4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.