security/cy2-otp - The NetBSD Packages Collection

Cyrus SASL OTP authentication plugin

SASL is a method for adding authentication support to connection-based
protocols.  To use SASL, a protocol includes a command for identifying and
authenticating a user to a server and for optionally negotiating protection
of subsequent protocol interactions.  If its use is negotiated, a security
layer is inserted between the protocol and the connection.

This is the Cyrus SASL plugin that implements the OTP authentication
mechanism.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/gmake

Runtime dependencies

security/cyrus-sasl security/cyrus-sasl security/cyrus-sasl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcy2-otp-2.1.27nb1.tgz
NetBSD 8.0earmv7hfcy2-otp-2.1.27nb1.tgz
NetBSD 8.0earmv7hfcy2-otp-2.1.27nb1.tgz
NetBSD 8.0i386cy2-otp-2.1.27nb1.tgz
NetBSD 8.0i386cy2-otp-2.1.27nb1.tgz
NetBSD 8.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 8.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 8.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 8.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 8.0x86_64cy2-otp-2.1.27nb1.tgz
NetBSD 8.0x86_64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0aarch64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0aarch64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0aarch64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0alphacy2-otp-2.1.27nb1.tgz
NetBSD 9.0alphacy2-otp-2.1.27nb1.tgz
NetBSD 9.0alphacy2-otp-2.1.27nb1.tgz
NetBSD 9.0earmv6hfcy2-otp-2.1.27nb1.tgz
NetBSD 9.0earmv6hfcy2-otp-2.1.27nb1.tgz
NetBSD 9.0earmv6hfcy2-otp-2.1.27nb1.tgz
NetBSD 9.0earmv7hfcy2-otp-2.1.27nb1.tgz
NetBSD 9.0earmv7hfcy2-otp-2.1.27nb1.tgz
NetBSD 9.0earmv7hfcy2-otp-2.1.27nb1.tgz
NetBSD 9.0earmv7hfcy2-otp-2.1.27nb1.tgz
NetBSD 9.0i386cy2-otp-2.1.27nb1.tgz
NetBSD 9.0i386cy2-otp-2.1.27nb1.tgz
NetBSD 9.0mips64ebcy2-otp-2.1.27nb1.tgz
NetBSD 9.0mips64ebcy2-otp-2.1.27nb1.tgz
NetBSD 9.0mips64ebcy2-otp-2.1.27nb1.tgz
NetBSD 9.0mips64ebcy2-otp-2.1.27nb1.tgz
NetBSD 9.0mips64ebcy2-otp-2.1.27nb1.tgz
NetBSD 9.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 9.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 9.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 9.0powerpccy2-otp-2.1.27nb1.tgz
NetBSD 9.0sparc64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0sparc64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0sparc64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0sparccy2-otp-2.1.27nb1.tgz
NetBSD 9.0sparccy2-otp-2.1.27nb1.tgz
NetBSD 9.0sparccy2-otp-2.1.27nb1.tgz
NetBSD 9.0sparccy2-otp-2.1.27nb1.tgz
NetBSD 9.0x86_64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0x86_64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0x86_64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0x86_64cy2-otp-2.1.27nb1.tgz
NetBSD 9.0x86_64cy2-otp-2.1.27nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.