security/cracklib - The NetBSD Packages Collection

Library used to enforce strong passwords

CrackLib is a library containing a C function (well, lots of functions
really, but you only need to use one of them) which may be used in a
"passwd"-like program.

The idea is simple: try to prevent users from choosing passwords that
could be guessed by "Crack" by filtering them out, at source.

CrackLib is an offshoot of the the version 5 "Crack" software, and
contains a considerable number of ideas nicked from the new software.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfcracklib-2.9.7.tgz
NetBSD 8.0earmv7hfcracklib-2.9.7.tgz
NetBSD 8.0earmv7hfcracklib-2.9.7.tgz
NetBSD 8.0i386cracklib-2.9.7.tgz
NetBSD 8.0i386cracklib-2.9.7.tgz
NetBSD 8.0powerpccracklib-2.9.7.tgz
NetBSD 8.0powerpccracklib-2.9.7.tgz
NetBSD 8.0powerpccracklib-2.9.7.tgz
NetBSD 8.0powerpccracklib-2.9.7.tgz
NetBSD 8.0x86_64cracklib-2.9.7.tgz
NetBSD 8.0x86_64cracklib-2.9.7.tgz
NetBSD 9.0aarch64cracklib-2.9.7.tgz
NetBSD 9.0aarch64cracklib-2.9.7.tgz
NetBSD 9.0aarch64cracklib-2.9.7.tgz
NetBSD 9.0alphacracklib-2.9.7.tgz
NetBSD 9.0alphacracklib-2.9.7.tgz
NetBSD 9.0alphacracklib-2.9.7.tgz
NetBSD 9.0earmcracklib-2.9.7.tgz
NetBSD 9.0earmcracklib-2.9.7.tgz
NetBSD 9.0earmcracklib-2.9.7.tgz
NetBSD 9.0earmv6hfcracklib-2.9.7.tgz
NetBSD 9.0earmv6hfcracklib-2.9.7.tgz
NetBSD 9.0earmv6hfcracklib-2.9.7.tgz
NetBSD 9.0earmv7hfcracklib-2.9.7.tgz
NetBSD 9.0earmv7hfcracklib-2.9.7.tgz
NetBSD 9.0earmv7hfcracklib-2.9.7.tgz
NetBSD 9.0earmv7hfcracklib-2.9.7.tgz
NetBSD 9.0i386cracklib-2.9.7.tgz
NetBSD 9.0i386cracklib-2.9.7.tgz
NetBSD 9.0i386cracklib-2.9.7.tgz
NetBSD 9.0mips64ebcracklib-2.9.7.tgz
NetBSD 9.0mips64ebcracklib-2.9.7.tgz
NetBSD 9.0mips64ebcracklib-2.9.7.tgz
NetBSD 9.0mips64ebcracklib-2.9.7.tgz
NetBSD 9.0mipselcracklib-2.9.7.tgz
NetBSD 9.0mipselcracklib-2.9.7.tgz
NetBSD 9.0mipselcracklib-2.9.7.tgz
NetBSD 9.0mipselcracklib-2.9.7.tgz
NetBSD 9.0powerpccracklib-2.9.7.tgz
NetBSD 9.0powerpccracklib-2.9.7.tgz
NetBSD 9.0powerpccracklib-2.9.7.tgz
NetBSD 9.0powerpccracklib-2.9.7.tgz
NetBSD 9.0sh3elcracklib-2.9.7.tgz
NetBSD 9.0sh3elcracklib-2.9.7.tgz
NetBSD 9.0sh3elcracklib-2.9.7.tgz
NetBSD 9.0sh3elcracklib-2.9.7.tgz
NetBSD 9.0sparc64cracklib-2.9.7.tgz
NetBSD 9.0sparc64cracklib-2.9.7.tgz
NetBSD 9.0sparc64cracklib-2.9.7.tgz
NetBSD 9.0sparccracklib-2.9.7.tgz
NetBSD 9.0sparccracklib-2.9.7.tgz
NetBSD 9.0sparccracklib-2.9.7.tgz
NetBSD 9.0sparccracklib-2.9.7.tgz
NetBSD 9.0vaxcracklib-2.9.7.tgz
NetBSD 9.0vaxcracklib-2.9.7.tgz
NetBSD 9.0vaxcracklib-2.9.7.tgz
NetBSD 9.0x86_64cracklib-2.9.7.tgz
NetBSD 9.0x86_64cracklib-2.9.7.tgz
NetBSD 9.0x86_64cracklib-2.9.7.tgz
NetBSD 9.0x86_64cracklib-2.9.7.tgz
NetBSD 9.0x86_64cracklib-2.9.7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.