security/ap-modsecurity2 - The NetBSD Packages Collection

Intrusion detection and prevention engine for web applications

ModSecurity is an open source intrusion detection and prevention engine for
web applications (or a web application firewall). Operating as an Apache Web
server module or standalone, the purpose of ModSecurity is to increase web
application security, protecting web applications from known and unknown
attacks.

This version is usable with apache 2.2 and 2.4.

Build dependencies

pkgtools/cwrappers devel/libtool-base lang/perl5

Runtime dependencies

www/apache24 devel/apr devel/apr-util textproc/libxml2 devel/pcre devel/readline lang/lua51 www/apache24 devel/apr-util textproc/libxml2 devel/pcre devel/readline

Available binary packages

aarch64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
aarch64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
aarch64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
alpha:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
alpha:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
earmv6hf:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
earmv6hf:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
earmv6hf:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
earmv6hf:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
earmv7hf:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 8.0)
earmv7hf:ap24-modsecurity-2.7.7nb19.tgz(NetBSD 8.0)
earmv7hf:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
earmv7hf:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
earmv7hf:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
earmv7hf:ap24-modsecurity-2.7.7nb19.tgz(NetBSD 9.0)
earmv7hf:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
earmv7hf:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
earmv7hf:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
i386:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
i386:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
i386:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 8.0)
i386:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
i386:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
i386:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
mips64eb:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
powerpc:ap24-modsecurity-2.7.7nb19.tgz(NetBSD 8.0)
powerpc:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
powerpc:ap24-modsecurity-2.7.7nb19.tgz(NetBSD 8.0)
powerpc:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
powerpc:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 8.0)
powerpc:ap24-modsecurity-2.7.7nb19.tgz(NetBSD 8.0)
powerpc:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
powerpc:ap24-modsecurity-2.7.7nb19.tgz(NetBSD 9.0)
powerpc:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
powerpc:ap24-modsecurity-2.7.7nb19.tgz(NetBSD 9.0)
powerpc:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
sparc64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
sparc64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
sparc:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
x86_64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 8.0)
x86_64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 8.0)
x86_64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb22.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)
x86_64:ap24-modsecurity-2.7.7nb23.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

curl
Enable curl support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]