security/R-askpass - The NetBSD Packages Collection

Safe password entry for R, Git, and SSH

Cross-platform utilities for prompting the user for credentials or a
passphrase, for example to authenticate with a server or read a
protected key. Includes native programs for MacOS and Windows, hence
no 'tcltk' is required. Password entry can be invoked in two different
ways: directly from R via the askpass() function, or indirectly as
password-entry back-end for 'ssh-agent' or 'git-credential' via the
SSH_ASKPASS and GIT_ASKPASS environment variables. Thereby the user
can be prompted for credentials or a passphrase if needed when R calls
out to git or ssh.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

sysutils/R-sys math/R math/R

Binary packages

OSArchitectureVersion
NetBSD 8.0i386R-askpass-1.1.tgz
NetBSD 8.0i386R-askpass-1.1.tgz
NetBSD 8.0powerpcR-askpass-1.1.tgz
NetBSD 8.0powerpcR-askpass-1.1.tgz
NetBSD 8.0powerpcR-askpass-1.1.tgz
NetBSD 8.0powerpcR-askpass-1.1.tgz
NetBSD 8.0x86_64R-askpass-1.1.tgz
NetBSD 8.0x86_64R-askpass-1.1.tgz
NetBSD 9.0aarch64R-askpass-1.1.tgz
NetBSD 9.0aarch64R-askpass-1.1.tgz
NetBSD 9.0aarch64R-askpass-1.1.tgz
NetBSD 9.0alphaR-askpass-1.1.tgz
NetBSD 9.0alphaR-askpass-1.1.tgz
NetBSD 9.0alphaR-askpass-1.1.tgz
NetBSD 9.0i386R-askpass-1.1.tgz
NetBSD 9.0i386R-askpass-1.1.tgz
NetBSD 9.0i386R-askpass-1.1.tgz
NetBSD 9.0powerpcR-askpass-1.1.tgz
NetBSD 9.0powerpcR-askpass-1.1.tgz
NetBSD 9.0powerpcR-askpass-1.1.tgz
NetBSD 9.0powerpcR-askpass-1.1.tgz
NetBSD 9.0sparc64R-askpass-1.1.tgz
NetBSD 9.0sparc64R-askpass-1.1.tgz
NetBSD 9.0sparc64R-askpass-1.1.tgz
NetBSD 9.0x86_64R-askpass-1.1.tgz
NetBSD 9.0x86_64R-askpass-1.1.tgz
NetBSD 9.0x86_64R-askpass-1.1.tgz
NetBSD 9.0x86_64R-askpass-1.1.tgz
NetBSD 9.0x86_64R-askpass-1.1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.