print/tex-hyph-utf8 - The NetBSD Packages Collection

Hyphenation patterns expressed in UTF-8

Modern native UTF-8 engines such as XeTeX and LuaTeX need
hyphenation patterns in UTF-8 format, whereas older systems
require hyphenation patterns in the 8-bit encoding of the font
in use (such encodings are codified in the LaTeX scheme with
names like OT1, T2A, TS1, OML, LY1, etc). The present package
offers a collection of conversions of existing patterns to
UTF-8 format, together with converters for use with 8-bit fonts
in older systems. Since hyphenation patterns for Knuthian-style
TeX systems are only read at iniTeX time, it is hoped that the
UTF-8 patterns, with their converters, will completely supplant
the older patterns.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

print/kpathsea

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 8.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 8.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 8.0earmv7hftex-hyph-utf8-2021.tgz
NetBSD 8.0i386tex-hyph-utf8-2020.tgz
NetBSD 8.0i386tex-hyph-utf8-2020.tgz
NetBSD 8.0i386tex-hyph-utf8-2020.tgz
NetBSD 8.0i386tex-hyph-utf8-2021.tgz
NetBSD 8.0powerpctex-hyph-utf8-2020.tgz
NetBSD 8.0powerpctex-hyph-utf8-2020.tgz
NetBSD 8.0powerpctex-hyph-utf8-2020.tgz
NetBSD 8.0powerpctex-hyph-utf8-2020.tgz
NetBSD 8.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 8.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 8.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 8.0x86_64tex-hyph-utf8-2021.tgz
NetBSD 9.0aarch64tex-hyph-utf8-2021.tgz
NetBSD 9.0aarch64tex-hyph-utf8-2020.tgz
NetBSD 9.0aarch64tex-hyph-utf8-2020.tgz
NetBSD 9.0aarch64tex-hyph-utf8-2020.tgz
NetBSD 9.0alphatex-hyph-utf8-2020.tgz
NetBSD 9.0alphatex-hyph-utf8-2021.tgz
NetBSD 9.0earmtex-hyph-utf8-2020.tgz
NetBSD 9.0earmtex-hyph-utf8-2021.tgz
NetBSD 9.0earmv6hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv6hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv6hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv6hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv6hftex-hyph-utf8-2021.tgz
NetBSD 9.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv7hftex-hyph-utf8-2020.tgz
NetBSD 9.0earmv7hftex-hyph-utf8-2021.tgz
NetBSD 9.0earmv7hftex-hyph-utf8-2021.tgz
NetBSD 9.0i386tex-hyph-utf8-2020.tgz
NetBSD 9.0i386tex-hyph-utf8-2020.tgz
NetBSD 9.0i386tex-hyph-utf8-2020.tgz
NetBSD 9.0i386tex-hyph-utf8-2021.tgz
NetBSD 9.0m68ktex-hyph-utf8-2020.tgz
NetBSD 9.0m68ktex-hyph-utf8-2020.tgz
NetBSD 9.0mips64ebtex-hyph-utf8-2020.tgz
NetBSD 9.0mips64ebtex-hyph-utf8-2020.tgz
NetBSD 9.0mips64ebtex-hyph-utf8-2020.tgz
NetBSD 9.0mips64ebtex-hyph-utf8-2021.tgz
NetBSD 9.0mipseltex-hyph-utf8-2020.tgz
NetBSD 9.0mipseltex-hyph-utf8-2020.tgz
NetBSD 9.0mipseltex-hyph-utf8-2021.tgz
NetBSD 9.0powerpctex-hyph-utf8-2020.tgz
NetBSD 9.0powerpctex-hyph-utf8-2020.tgz
NetBSD 9.0powerpctex-hyph-utf8-2020.tgz
NetBSD 9.0powerpctex-hyph-utf8-2020.tgz
NetBSD 9.0powerpctex-hyph-utf8-2020.tgz
NetBSD 9.0sh3eltex-hyph-utf8-2020.tgz
NetBSD 9.0sh3eltex-hyph-utf8-2020.tgz
NetBSD 9.0sh3eltex-hyph-utf8-2020.tgz
NetBSD 9.0sh3eltex-hyph-utf8-2021.tgz
NetBSD 9.0sparc64tex-hyph-utf8-2020.tgz
NetBSD 9.0sparc64tex-hyph-utf8-2021.tgz
NetBSD 9.0sparctex-hyph-utf8-2020.tgz
NetBSD 9.0sparctex-hyph-utf8-2020.tgz
NetBSD 9.0sparctex-hyph-utf8-2020.tgz
NetBSD 9.0sparctex-hyph-utf8-2021.tgz
NetBSD 9.0vaxtex-hyph-utf8-2020.tgz
NetBSD 9.0vaxtex-hyph-utf8-2020.tgz
NetBSD 9.0vaxtex-hyph-utf8-2021.tgz
NetBSD 9.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 9.0x86_64tex-hyph-utf8-2021.tgz
NetBSD 9.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 9.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 9.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 9.0x86_64tex-hyph-utf8-2020.tgz
NetBSD 9.0x86_64tex-hyph-utf8-2021.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.