print/tex-context-vim - The NetBSD Packages Collection

Generate ConTeXt syntax highlighting code from vim

ConTeXt has excellent pretty printing capabilities for many
languages. The code for pretty printing is written in TeX, and
due to catcode juggling, such verbatim typesetting is perhaps
the trickiest part of TeX. This makes it difficult for a
"normal" user to define syntax highlighting rules for a new
language. This module takes the onus of defining syntax
highlighting rules away from the user and uses ViM editor to
generate the syntax highlighting. There is a helper
2context.vim script to do the syntax parsing in ViM.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

print/tex-context print/tex-context-filter print/kpathsea

Binary packages

OSArchitectureVersion
NetBSD 8.0i386tex-context-vim-2020.tgz
NetBSD 8.0i386tex-context-vim-2020.tgz
NetBSD 8.0i386tex-context-vim-2020.56356.tgz
NetBSD 8.0powerpctex-context-vim-2020.tgz
NetBSD 8.0powerpctex-context-vim-2020.56356.tgz
NetBSD 8.0powerpctex-context-vim-2020.tgz
NetBSD 8.0powerpctex-context-vim-2020.56356.tgz
NetBSD 8.0x86_64tex-context-vim-2020.56356.tgz
NetBSD 8.0x86_64tex-context-vim-2020.tgz
NetBSD 8.0x86_64tex-context-vim-2020.tgz
NetBSD 9.0aarch64tex-context-vim-2020.56356.tgz
NetBSD 9.0aarch64tex-context-vim-2020.tgz
NetBSD 9.0aarch64tex-context-vim-2020.tgz
NetBSD 9.0i386tex-context-vim-2020.tgz
NetBSD 9.0i386tex-context-vim-2020.tgz
NetBSD 9.0i386tex-context-vim-2020.56356.tgz
NetBSD 9.0powerpctex-context-vim-2020.tgz
NetBSD 9.0powerpctex-context-vim-2020.tgz
NetBSD 9.0powerpctex-context-vim-2020.56356.tgz
NetBSD 9.0powerpctex-context-vim-2020.56356.tgz
NetBSD 9.0x86_64tex-context-vim-2020.tgz
NetBSD 9.0x86_64tex-context-vim-2020.tgz
NetBSD 9.0x86_64tex-context-vim-2020.tgz
NetBSD 9.0x86_64tex-context-vim-2020.56356.tgz
NetBSD 9.0x86_64tex-context-vim-2020.tgz
NetBSD 9.0x86_64tex-context-vim-2020.tgz
NetBSD 9.0x86_64tex-context-vim-2020.56356.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.