print/sile - The NetBSD Packages Collection

Modern Layout Engine with Lua based scripting

SILE is a typesetting system; its job is to produce beautiful printed
documents. Conceptually, SILE is similar to TeX - from which it borrows
some concepts and even syntax and algorithms - but the similarities end
there. Rather than being a derivative of the TeX family SILE is a new
typesetting and layout engine written from the ground up using modern
technologies and borrowing some ideas from graphical systems such as
InDesign.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/gmake devel/pkgconf

Runtime dependencies

archivers/lua-zlib devel/lua-bit32 devel/lua-cliargs devel/lua-compat53 devel/lua-epnf devel/lua-filesystem devel/lua-linenoise devel/lua-lpeg devel/lua-penlight devel/lua-repl devel/lua-stdlib devel/lua-vstruct math/lua-cassowary net/lua-socket security/lua-sec textproc/lua-expat textproc/lua-cosmo textproc/lua-utf8 fonts/fontconfig fonts/fontconfig graphics/freetype2 graphics/freetype2 fonts/harfbuzz graphics/png lang/lua53 textproc/icu fonts/fontconfig fonts/harfbuzz graphics/png textproc/icu

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfsile-0.10.12nb1.tgz
NetBSD 8.0earmv7hfsile-0.10.9nb1.tgz
NetBSD 8.0earmv7hfsile-0.10.15.tgz
NetBSD 8.0i386sile-0.10.9nb1.tgz
NetBSD 8.0i386sile-0.10.12nb1.tgz
NetBSD 8.0i386sile-0.10.15.tgz
NetBSD 8.0powerpcsile-0.10.9nb1.tgz
NetBSD 8.0powerpcsile-0.10.15.tgz
NetBSD 8.0powerpcsile-0.10.12nb1.tgz
NetBSD 8.0powerpcsile-0.10.15.tgz
NetBSD 8.0x86_64sile-0.10.15.tgz
NetBSD 8.0x86_64sile-0.10.9nb1.tgz
NetBSD 8.0x86_64sile-0.10.12nb1.tgz
NetBSD 9.0aarch64sile-0.10.15.tgz
NetBSD 9.0aarch64sile-0.10.9nb1.tgz
NetBSD 9.0aarch64sile-0.10.12nb1.tgz
NetBSD 9.0alphasile-0.10.15.tgz
NetBSD 9.0alphasile-0.10.9nb1.tgz
NetBSD 9.0alphasile-0.10.12nb1.tgz
NetBSD 9.0earmv6hfsile-0.10.15.tgz
NetBSD 9.0earmv6hfsile-0.10.9nb1.tgz
NetBSD 9.0earmv6hfsile-0.10.12nb1.tgz
NetBSD 9.0earmv6hfsile-0.10.12nb1.tgz
NetBSD 9.0earmv7hfsile-0.10.15.tgz
NetBSD 9.0earmv7hfsile-0.10.9nb1.tgz
NetBSD 9.0earmv7hfsile-0.10.12nb1.tgz
NetBSD 9.0earmv7hfsile-0.10.12nb1.tgz
NetBSD 9.0earmv7hfsile-0.10.15.tgz
NetBSD 9.0i386sile-0.10.9nb1.tgz
NetBSD 9.0i386sile-0.10.12nb1.tgz
NetBSD 9.0i386sile-0.10.15.tgz
NetBSD 9.0mips64ebsile-0.10.15.tgz
NetBSD 9.0mips64ebsile-0.10.9nb1.tgz
NetBSD 9.0mips64ebsile-0.10.12nb1.tgz
NetBSD 9.0powerpcsile-0.10.12nb1.tgz
NetBSD 9.0powerpcsile-0.10.15.tgz
NetBSD 9.0powerpcsile-0.10.15.tgz
NetBSD 9.0sparc64sile-0.10.15.tgz
NetBSD 9.0sparc64sile-0.10.9nb1.tgz
NetBSD 9.0sparc64sile-0.10.12nb1.tgz
NetBSD 9.0x86_64sile-0.10.12nb1.tgz
NetBSD 9.0x86_64sile-0.10.12nb1.tgz
NetBSD 9.0x86_64sile-0.10.12nb1.tgz
NetBSD 9.0x86_64sile-0.10.15.tgz
NetBSD 9.0x86_64sile-0.10.9nb1.tgz
NetBSD 9.0x86_64sile-0.10.12nb1.tgz
NetBSD 9.0x86_64sile-0.10.15.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.