print/pslib - The NetBSD Packages Collection

C-library to create PostScript files

pslib is a C-library for generating PostScript files with little
effort. It offers an easy way of generating PostScript text
and graphics. Its text function are very sophisticated and support
kerning, ligatures and some basic formatting. Hypertext functions
are supported through pdfmarks which makes pslib in combination
with ghostscript a viable alternative for libraries creating
PDF.

Build dependencies

textproc/p5-XML-Parser pkgtools/cwrappers devel/libtool-base devel/gmake lang/perl5

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 8.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 8.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 8.0i386pslib-0.4.5nb6.tgz
NetBSD 8.0i386pslib-0.4.5nb6.tgz
NetBSD 8.0i386pslib-0.4.5nb6.tgz
NetBSD 8.0powerpcpslib-0.4.5nb6.tgz
NetBSD 8.0powerpcpslib-0.4.5nb6.tgz
NetBSD 8.0powerpcpslib-0.4.5nb6.tgz
NetBSD 8.0powerpcpslib-0.4.5nb6.tgz
NetBSD 8.0x86_64pslib-0.4.5nb6.tgz
NetBSD 8.0x86_64pslib-0.4.5nb6.tgz
NetBSD 8.0x86_64pslib-0.4.5nb6.tgz
NetBSD 9.0aarch64pslib-0.4.5nb6.tgz
NetBSD 9.0aarch64pslib-0.4.5nb6.tgz
NetBSD 9.0aarch64pslib-0.4.5nb6.tgz
NetBSD 9.0alphapslib-0.4.5nb6.tgz
NetBSD 9.0alphapslib-0.4.5nb6.tgz
NetBSD 9.0alphapslib-0.4.5nb6.tgz
NetBSD 9.0earmpslib-0.4.5nb6.tgz
NetBSD 9.0earmpslib-0.4.5nb6.tgz
NetBSD 9.0earmpslib-0.4.5nb6.tgz
NetBSD 9.0earmv6hfpslib-0.4.5nb6.tgz
NetBSD 9.0earmv6hfpslib-0.4.5nb6.tgz
NetBSD 9.0earmv6hfpslib-0.4.5nb6.tgz
NetBSD 9.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 9.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 9.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 9.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 9.0earmv7hfpslib-0.4.5nb6.tgz
NetBSD 9.0i386pslib-0.4.5nb6.tgz
NetBSD 9.0i386pslib-0.4.5nb6.tgz
NetBSD 9.0i386pslib-0.4.5nb6.tgz
NetBSD 9.0mips64ebpslib-0.4.5nb6.tgz
NetBSD 9.0mips64ebpslib-0.4.5nb6.tgz
NetBSD 9.0mips64ebpslib-0.4.5nb6.tgz
NetBSD 9.0mipselpslib-0.4.5nb6.tgz
NetBSD 9.0mipselpslib-0.4.5nb6.tgz
NetBSD 9.0powerpcpslib-0.4.5nb6.tgz
NetBSD 9.0powerpcpslib-0.4.5nb6.tgz
NetBSD 9.0powerpcpslib-0.4.5nb6.tgz
NetBSD 9.0powerpcpslib-0.4.5nb6.tgz
NetBSD 9.0sh3elpslib-0.4.5nb6.tgz
NetBSD 9.0sh3elpslib-0.4.5nb6.tgz
NetBSD 9.0sparc64pslib-0.4.5nb6.tgz
NetBSD 9.0sparc64pslib-0.4.5nb5.tgz
NetBSD 9.0sparc64pslib-0.4.5nb6.tgz
NetBSD 9.0sparc64pslib-0.4.5nb6.tgz
NetBSD 9.0sparcpslib-0.4.5nb6.tgz
NetBSD 9.0sparcpslib-0.4.5nb6.tgz
NetBSD 9.0sparcpslib-0.4.5nb6.tgz
NetBSD 9.0vaxpslib-0.4.5nb6.tgz
NetBSD 9.0vaxpslib-0.4.5nb6.tgz
NetBSD 9.0x86_64pslib-0.4.5nb6.tgz
NetBSD 9.0x86_64pslib-0.4.5nb6.tgz
NetBSD 9.0x86_64pslib-0.4.5nb6.tgz
NetBSD 9.0x86_64pslib-0.4.5nb6.tgz
NetBSD 9.0x86_64pslib-0.4.5nb6.tgz
NetBSD 9.0x86_64pslib-0.4.5nb6.tgz
NetBSD 9.0x86_64pslib-0.4.5nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.