print/poppler-qt5 - The NetBSD Packages Collection

PDF rendering library (QT5 wrapper)

This is the QT5 wrapper for poppler, a PDF rendering library. It
is a fork of the xpdf 3.0 PDF viewer developed by Derek Noonburg
of Glyph and Cog, LLC.

Poppler provides PDF rendering functionality as a shared library,
to centralize the maintenence effort and to reduce duplicated
effort. And the poppler developers would like to move libpoppler
forward in a number of areas that doesn't fit within the goals of
xpdf.

Build dependencies

pkgtools/x11-links devel/boost-headers x11/xcb-proto x11/xorgproto pkgtools/cwrappers devel/glib2-tools devel/cmake devel/pkgconf

Runtime dependencies

graphics/openjpeg print/poppler print/poppler x11/qt5-qtbase x11/qt5-qtbase

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpoppler-qt5-20.11.0.tgz
NetBSD 8.0earmv7hfpoppler-qt5-21.01.0.tgz
NetBSD 8.0i386poppler-qt5-0.87.0nb3.tgz
NetBSD 8.0i386poppler-qt5-20.11.0.tgz
NetBSD 8.0i386poppler-qt5-21.01.0.tgz
NetBSD 8.0powerpcpoppler-qt5-0.87.0nb3.tgz
NetBSD 8.0powerpcpoppler-qt5-21.01.0.tgz
NetBSD 8.0powerpcpoppler-qt5-20.11.0.tgz
NetBSD 8.0powerpcpoppler-qt5-21.01.0.tgz
NetBSD 8.0x86_64poppler-qt5-21.01.0.tgz
NetBSD 8.0x86_64poppler-qt5-0.87.0nb3.tgz
NetBSD 8.0x86_64poppler-qt5-20.11.0.tgz
NetBSD 9.0aarch64poppler-qt5-21.01.0.tgz
NetBSD 9.0aarch64poppler-qt5-0.87.0nb3.tgz
NetBSD 9.0aarch64poppler-qt5-20.11.0.tgz
NetBSD 9.0alphapoppler-qt5-21.01.0.tgz
NetBSD 9.0alphapoppler-qt5-0.87.0nb3.tgz
NetBSD 9.0alphapoppler-qt5-20.11.0.tgz
NetBSD 9.0earmpoppler-qt5-21.01.0.tgz
NetBSD 9.0earmv6hfpoppler-qt5-21.01.0.tgz
NetBSD 9.0earmv6hfpoppler-qt5-0.87.0nb3.tgz
NetBSD 9.0earmv6hfpoppler-qt5-20.11.0.tgz
NetBSD 9.0earmv6hfpoppler-qt5-20.11.0.tgz
NetBSD 9.0earmv7hfpoppler-qt5-21.01.0.tgz
NetBSD 9.0earmv7hfpoppler-qt5-0.87.0nb3.tgz
NetBSD 9.0earmv7hfpoppler-qt5-20.11.0.tgz
NetBSD 9.0earmv7hfpoppler-qt5-20.11.0.tgz
NetBSD 9.0earmv7hfpoppler-qt5-21.01.0.tgz
NetBSD 9.0i386poppler-qt5-0.87.0nb3.tgz
NetBSD 9.0i386poppler-qt5-20.11.0.tgz
NetBSD 9.0i386poppler-qt5-21.01.0.tgz
NetBSD 9.0mips64ebpoppler-qt5-21.01.0.tgz
NetBSD 9.0mips64ebpoppler-qt5-0.87.0nb3.tgz
NetBSD 9.0mips64ebpoppler-qt5-20.11.0.tgz
NetBSD 9.0powerpcpoppler-qt5-20.11.0.tgz
NetBSD 9.0powerpcpoppler-qt5-0.87.0nb3.tgz
NetBSD 9.0powerpcpoppler-qt5-21.01.0.tgz
NetBSD 9.0powerpcpoppler-qt5-21.01.0.tgz
NetBSD 9.0sparc64poppler-qt5-21.01.0.tgz
NetBSD 9.0sparc64poppler-qt5-0.87.0nb2.tgz
NetBSD 9.0sparc64poppler-qt5-0.87.0nb3.tgz
NetBSD 9.0sparc64poppler-qt5-20.11.0.tgz
NetBSD 9.0x86_64poppler-qt5-20.11.0.tgz
NetBSD 9.0x86_64poppler-qt5-20.11.0.tgz
NetBSD 9.0x86_64poppler-qt5-21.01.0.tgz
NetBSD 9.0x86_64poppler-qt5-21.01.0.tgz
NetBSD 9.0x86_64poppler-qt5-0.87.0nb3.tgz
NetBSD 9.0x86_64poppler-qt5-20.11.0.tgz
NetBSD 9.0x86_64poppler-qt5-21.01.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.