print/p5-LaTeX-Encode - The NetBSD Packages Collection

Encode characters for LaTeX formatting

This module provides a function to encode text that is to be formatted with
LaTeX. It encodes characters that are special to LaTeX or that are
represented in LaTeX by LaTeX commands.

The special characters are: \ (command character), { (open group), }
(end group), & (table column separator), # (parameter specifier),
% (comment character), _ (subscript), ^ (superscript),
~ (non-breakable space), $ (mathematics mode).

Note that some of the LaTeX commands for characters are defined in the LaTeX
textcomp package. If your text includes such characters, you will need to
include the following lines in the preamble to your LaTeX document.

    \usepackage[T1]{fontenc}
    \usepackage{textcomp}

The function is useful for encoding data that is interpolated into LaTeX
document templates, say with Template::Plugin::Latex (shameless plug!).

Build dependencies

devel/p5-Carp-Always pkgtools/cwrappers

Runtime dependencies

devel/p5-Readonly lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0i386p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0i386p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0i386p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 8.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0aarch64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0aarch64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0aarch64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0alphap5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0alphap5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0alphap5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv6hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv6hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv6hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv6hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0earmv7hfp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0i386p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0i386p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0i386p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0mips64ebp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0mips64ebp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0mips64ebp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0powerpcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sh3elp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sh3elp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sparc64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sparc64p5-LaTeX-Encode-0.092.0nb2.tgz
NetBSD 9.0sparc64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sparc64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sparcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sparcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0sparcp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0vaxp5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz
NetBSD 9.0x86_64p5-LaTeX-Encode-0.092.0nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.