print/ghostscript-gpl - The NetBSD Packages Collection

Postscript interpreter

Ghostscript is the well-known PostScript interpreter which is available for
all common and most esoteric platforms and supports many different printers
and some displays.

Support for Cups is enabled by the "cups" option (off by default).

This package contains Ghostscript 9.06, the last Ghostscript release
under GPL3 (August, 2012).  Newer releases are under AGPL3 (see
ghostscript-agpl); this package exists for those that prefer an old
GPL3 version to the AGPL3 version maintained by upstream.

Build dependencies

pkgtools/x11-links x11/xcb-proto x11/xorgproto pkgtools/cwrappers devel/gmake devel/pkgconf

Runtime dependencies

fonts/ghostscript-fonts lang/perl5 x11/libxcb graphics/freetype2 graphics/freetype2 fonts/fontconfig fonts/fontconfig graphics/png graphics/tiff print/libpaper fonts/fontconfig graphics/png graphics/tiff

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfghostscript-gpl-9.06nb37.tgz
NetBSD 8.0earmv7hfghostscript-gpl-9.06nb36.tgz
NetBSD 8.0earmv7hfghostscript-gpl-9.06nb37.tgz
NetBSD 8.0i386ghostscript-gpl-9.06nb37.tgz
NetBSD 8.0i386ghostscript-gpl-9.06nb37.tgz
NetBSD 8.0powerpcghostscript-gpl-9.06nb36.tgz
NetBSD 8.0powerpcghostscript-gpl-9.06nb37.tgz
NetBSD 8.0powerpcghostscript-gpl-9.06nb37.tgz
NetBSD 8.0powerpcghostscript-gpl-9.06nb37.tgz
NetBSD 8.0x86_64ghostscript-gpl-9.06nb37.tgz
NetBSD 8.0x86_64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0aarch64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0aarch64ghostscript-gpl-9.06nb36.tgz
NetBSD 9.0aarch64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0alphaghostscript-gpl-9.06nb37.tgz
NetBSD 9.0alphaghostscript-gpl-9.06nb36.tgz
NetBSD 9.0alphaghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmv6hfghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmv6hfghostscript-gpl-9.06nb36.tgz
NetBSD 9.0earmv6hfghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmv6hfghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmv7hfghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmv7hfghostscript-gpl-9.06nb36.tgz
NetBSD 9.0earmv7hfghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmv7hfghostscript-gpl-9.06nb37.tgz
NetBSD 9.0earmv7hfghostscript-gpl-9.06nb37.tgz
NetBSD 9.0i386ghostscript-gpl-9.06nb36.tgz
NetBSD 9.0i386ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0i386ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0mips64ebghostscript-gpl-9.06nb37.tgz
NetBSD 9.0mips64ebghostscript-gpl-9.06nb36.tgz
NetBSD 9.0mips64ebghostscript-gpl-9.06nb37.tgz
NetBSD 9.0mipselghostscript-gpl-9.06nb37.tgz
NetBSD 9.0mipselghostscript-gpl-9.06nb37.tgz
NetBSD 9.0powerpcghostscript-gpl-9.06nb37.tgz
NetBSD 9.0powerpcghostscript-gpl-9.06nb36.tgz
NetBSD 9.0powerpcghostscript-gpl-9.06nb37.tgz
NetBSD 9.0powerpcghostscript-gpl-9.06nb37.tgz
NetBSD 9.0sh3elghostscript-gpl-9.06nb37.tgz
NetBSD 9.0sh3elghostscript-gpl-9.06nb37.tgz
NetBSD 9.0sparc64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0sparc64ghostscript-gpl-9.06nb34.tgz
NetBSD 9.0sparc64ghostscript-gpl-9.06nb36.tgz
NetBSD 9.0sparc64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0sparcghostscript-gpl-9.06nb37.tgz
NetBSD 9.0sparcghostscript-gpl-9.06nb36.tgz
NetBSD 9.0sparcghostscript-gpl-9.06nb37.tgz
NetBSD 9.0vaxghostscript-gpl-9.06nb37.tgz
NetBSD 9.0x86_64ghostscript-gpl-9.06nb36.tgz
NetBSD 9.0x86_64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0x86_64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0x86_64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0x86_64ghostscript-gpl-9.06nb36.tgz
NetBSD 9.0x86_64ghostscript-gpl-9.06nb37.tgz
NetBSD 9.0x86_64ghostscript-gpl-9.06nb37.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

cups
Enable cups (Common UNIX Printing System) support.
debug
Enable debugging facilities in the package.
disable-compile-inits
Disable compile time implicit initialization.
fontconfig
Enable FONTCONFIG (fonts/fontconfig) support.
utf8
Enable UTF-8 (iconv) character encoding support.
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.